
  <!DOCTYPE html>
        <html lang="en">
        <head>
<base href="https://trinidadexpress.com/content/tncms/live/" />
<meta name="keywords" content="editorials, opinion" />
<meta name="news_keywords" content="editorials, opinion" />
<meta name="description" content="CARIBBEAN countries joined with others across the world on Sunday to mark the 37th anniversary of the collapse of a socialist experiment which had been undertaken neighbouring Grenada four and" />
<meta name="author" content="" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<meta name="apple-mobile-web-app-capable" content="yes" />
<meta name="apple-mobile-web-app-status-bar-style" content="black-translucent" />
<meta name="apple-itunes-app" content="app-id=1325154430" />
<meta name="google-play-app" content="app-id=com.trinidadexpress.android.prod:" />
<meta name="google-site-verification" content="googlef25059520416481b" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://trinidadexpress.com/opinion/editorials/grenada-37-years-later/article_7e9a8a48-17e2-11eb-bb19-d3db743fecbd.html" />
<meta property="og:image" content="https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/content/tncms/assets/v3/editorial/4/10/410f1484-2337-11e8-bb31-277e215e09e6/5aa1e025dfd39.image.jpg?resize=730%2C561" />
<meta property="og:image:width" content="730" />
<meta property="og:image:height" content="561" />
<meta property="og:title" content="Grenada, 37  years later" />
<meta property="og:description" content="CARIBBEAN countries joined with others across the world on Sunday to mark the 37th anniversary of the collapse of a socialist experiment which had been undertaken neighbouring Grenada four and" />
<meta property="og:site_name" content="Trinidad Express Newspapers" />
<meta property="og:section" content="Editorial" />
<meta property="fb:app_id" content="731512153573124" />
<meta property="article:publisher" content="https://www.facebook.com/ExpressNewspapers" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@expressupdates" />
<meta name="twitter:image:alt" content="Express Editorial : Daily" />
<meta property="fb:pages" content="134545155813" />
<meta property="tncms:ads" content="lazyload,refresh" />
<link rel="manifest" href="/tncms/messaging/manifest/" />
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/styles/bootstrap.min.44f4ed00052aeaf66307fd409db0d101.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/styles/layout.5cfe8d2b6e902b79c4710d15b491c631.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/shared-content/art/tncms/templates/libraries/flex/components/themes/resources/styles/theme-basic.c9c732b035a293475d6df8121863ef5a.css"/>
<link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Merriweather:400,600,700|Open+Sans:400,700,600,900|Montserrat:400,800|Lato:700,900"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/styles/flex-notification-controls.e115619c5ab5d4eb38fbd29cc0d2ea9b.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/styles/flex-utility-text-promo.945a2efac4892ce469180c513f411107.css"/>
<style>/*<![CDATA[*/ #tncms-block-615249 .tnt-prop-img { max-width: 69px; } .follow-links-615299 li { margin-right: 1px; padding: 0; } .follow-links-615299 li a, .follow-links-615299 li a:focus, .follow-links-615299 li a:active { ; color: #fff!important; font-size: 18px; margin-right: 10px; opacity: .8; padding:0; box-shadow: none; } .follow-links-615299 li a:hover { text-decoration: none; opacity: 1; } .follow-links-615299 li a.fb:hover { color: #3A59A5; } .follow-links-615299 li a.tw:hover { color: #46C8F9; } .follow-links-615299 li a.is:hover { color: #D4C4A2; } .follow-links-615299 li a.li:hover { color: #000; } .follow-links-615299 li a.li:hover { color: #5FC9F8; } .follow-links-615299 li a.li:hover { color: #A4C639; } #user-controls-615302 .user-controls .dropdown-menu > li > a { padding: 5px 20px; } #user-controls-615302 .tn-user-screenname, #user-controls-615302 .large-user-controls .user-welcome { padding: 0 5px; max-width: 75px; text-overflow: ellipsis; white-space: nowrap; overflow: hidden; } #user-controls-615302 .large-user-controls .user-welcome { padding:0; max-width: 100%; font-weight: bold; } #user-controls-615302 .dropdown-signup { font-size: 12px; } #user-controls-615302 .large-user-controls .tn-user-screenname { padding: 0; } #user-controls-615302 .large-user-avatar { margin-right: 10px; } #user-controls-615302 .large-user-controls { font-size: 12px; } #user-controls-615302 .logout-btn { cursor: pointer; } #user-controls-615302 .login-btn { background-color: #555; border-color: #555; } #user-controls-615302 .login-btn:hover { text-decoration: underline; } .notification-button.stuck .badge-dot { background-color:#ff0000; } #ad-638026 { min-height: 90px; min-width: 728px; } #ad-981235 { min-height: 1px; min-width: 1px; } #tncms-block-615294 .tnt-prop-img { max-width: 646px; } #tncms-block-632167 .tnt-prop-img { max-width: 646px; } #tncms-block-632169 .tnt-prop-img { max-width: 646px; } #block-615297 .search-spinner { position: absolute; } #block-615297 .input-group-btn:last-child > .btn, .input-group-btn:last-child > .btn-group { margin-left: 0; } #site-search-615297-dropdown.site-search-full .dropdown-menu .form-control { border: none; box-shadow: none; } #site-search-615297-dropdown.site-search-full .dropdown-menu .btn { border-radius: 2px; } #site-search-615297-btn { background-color: #000; border-color: #000; } #site-search-615297-btn { color: #fff; } #ad-637729 { min-height: 250px; min-width: 300px; } #block-636623 .tnt-slider-controls { text-align: right; padding-bottom: 30px; margin: 10px 0px; position: relative; top: 0%; transform: translateY(0%); -webkit-transform: translateY(0%); -ms-transform: translateY(0%); } #block-636623 .tnt-slider-previous { display: inline-block; margin-bottom: 0; font-weight: normal; text-align: center; vertical-align: middle; -ms-touch-action: manipulation; touch-action: manipulation; cursor: pointer; background-image: none; border: 1px solid #ccc; white-space: nowrap; -webkit-user-select: none; -moz-user-select: none; -ms-user-select: none; user-select: none; padding: 5px 10px; font-size: 12px; line-height: 1.5; position: absolute; right: 35px; } #block-636623 .tnt-slider-next { display: inline-block; margin-bottom: 0; font-weight: normal; text-align: center; vertical-align: middle; -ms-touch-action: manipulation; touch-action: manipulation; cursor: pointer; background-image: none; border: 1px solid #ccc; white-space: nowrap; -webkit-user-select: none; -moz-user-select: none; -ms-user-select: none; user-select: none; padding: 5px 10px; font-size: 12px; line-height: 1.5; position: absolute; right: 0px; } #ad-631850 { min-height: 250px; min-width: 300px; } #block-643313 .list-popular > li:before { background-color: #AAA; } #ad-632079 { min-height: 600px; min-width: 300px; } #tncms-block-631846 .tnt-prop-img { max-width: 52px; } #ad-632080 { min-height: 250px; min-width: 300px; } #tncms-block-615295 .tnt-prop-img { max-width: 409px; } #site-logo-615295 { color: #666; } #ad-637662 { min-height: 50px; min-width: 320px; } #ad-637662 { min-height: 50px; min-width: 320px; } /*]]>*/</style>
<script type="text/javascript">(function(){var tnsrc=window.location.hash.match(/[&#]tncms-source=([^&]+)/);var dl = window.dataLayer = window.dataLayer || [];dl.push({"tncms":{"template":{"version":"3.155.0"},"page":{"grid":"mobile_pattern","style":"default","path":"\/opinion\/editorials","syndicated":"false","reaction":"false","app":"editorial","theme":"flex","skin":"flex-editorial","http_status":200},"subscription":{"required":"false"},"vendor":{"outbrain":"headlines","taboola":"","chartbeat":"61692"},"system":{"render_time":234},"client":{"is_bot":"no","is_gdpr":"yes"},"asset":{"id":"7e9a8a48-17e2-11eb-bb19-d3db743fecbd","app":"editorial"},"google":{"ua":"UA-18252895-1"}}});if (tnsrc && tnsrc[1]) {dl.push({'tncms.campaign.internal_source': tnsrc[1]});}window.addEventListener("DOMContentLoaded", function(oEvent) {var oTest = document.createElement('div');oTest.innerHTML = '&nbsp;';oTest.className = 'adsbox';document.body.appendChild(oTest);var nTimeoutID = window.setTimeout(function() {if (oTest.offsetHeight === 0) {dl.push({'event': 'tncms.ad.blocked'});}document.body.removeChild(oTest);window.clearTimeout(nTimeoutID);}, 100);});var nWidth=Math.max(document.documentElement.clientWidth, window.innerWidth || 0),aBPs=[[300,"Extra small: Most smartphones."],[768,"Small: Tablet devices."],[992,"Medium: Laptops & landscape tablets."],[1200,"Large: Desktop computers."]],i,c,aThisBP,aBP;for(i=0,c=aBPs.length;i<c;i++){aThisBP=aBPs[i];if(aBP===undefined||aThisBP[0]<=nWidth){aBP=aThisBP;}}if(aBP!==undefined){dl.push({'tncms.client.breakpoint':aBP[1]});}(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'tncms.start':new Date().getTime(),event:'tncms.start'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl+ '&gtm_auth=UaWpb3d_PDCaIVzoLRLRYA&gtm_preview=env-2&gtm_cookies_win=x';f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-PDQV3N');})();</script>
<script src="https://bc.marfeelcache.com/statics/marfeel/gardac-sync.js" data-cfasync="false" data-mrf-script="garda" data-mrf-dt="1" data-mrf-host="bc.marfeelcache.com"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/shared-content/art/tncms/templates/libraries/flex/components/jquery/resources/scripts/jquery.min.6edb5af3e93b0a377ec925c5f1c6ddde.js"></script>
<script src="/shared-content/art/tncms/user/user.js"></script>
<script>/*<![CDATA[*/ TNCMS.User.restorePersistentSession(); /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/scripts/bootstrap.min.d457560d3dfbf1d56a225eb99d7b0702.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/common.5ee3960b4d37bc106988fa535b393865.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.ac87000c8e1356e20584473075fd0f2e.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/application.93d1db0a57d520951552a1dcd8fd9aeb.js"></script>
<script src="https://polyfill.io/v3/polyfill.min.js?features=default,fetch,IntersectionObserver,NodeList.prototype.@@iterator,Element.prototype.classList|gated" nomodule="nomodule"></script>
<script async="async" src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>/*<![CDATA[*/ window.googletag = window.googletag || {cmd: []};
    window.gptAdSlots = window.gptAdSlots || [];

    window.__tnt = window.__tnt || {};
    __tnt.ads = __tnt.ads || {};
    __tnt.ads.dfp = __tnt.ads.dfp || {};

    __tnt.ads.dfp.targeting = __tnt.ads.dfp.targeting || {};
    __tnt.ads.dfp.targeting.k = ["editorials","opinion"];

    __tnt.ads.dfp.targeting.page = ["asset","article","app-editorial"];
    __tnt.ads.dfp.templates = __tnt.ads.dfp.templates || {};
    __tnt.ads.dfp.templates = {
        interstitial:"https:\/\/bloximages.newyork1.vip.townnews.com\/trinidadexpress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/interstitial.7047e23fde50ef7dc7625903de95abec.js",
        pageCurl:"https:\/\/bloximages.newyork1.vip.townnews.com\/trinidadexpress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/page-curl.ca0c1a7372c29272ef1ccf504ced01a9.js",
        parallax:"https:\/\/bloximages.newyork1.vip.townnews.com\/trinidadexpress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/parallax.0ce32932f3b4125f930bea8d431f8f03.js",
        paw:"https:\/\/bloximages.newyork1.vip.townnews.com\/trinidadexpress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/paw.f2c3f73025b675e671c97fb411b2228d.js",
        pencil:"https:\/\/bloximages.newyork1.vip.townnews.com\/trinidadexpress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/pencil.7d33f5d95dc0b3cd3fe8f11229d905ca.js",
        reveal:"https:\/\/bloximages.newyork1.vip.townnews.com\/trinidadexpress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/reveal.e5d561a6b71aa2730a07fa90f5f4f6d6.js",
        stickyAnchor:"https:\/\/bloximages.newyork1.vip.townnews.com\/trinidadexpress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/sticky-anchor.834cbe7aa25c4d789bfb4c362348b677.js",
        video:"https:\/\/bloximages.newyork1.vip.townnews.com\/trinidadexpress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/video-inline.9b0997ab77d1d69707d283848faeacdd.js",
        wallpaper:"https:\/\/bloximages.newyork1.vip.townnews.com\/trinidadexpress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/wallpaper.dc1c1bace62343a130be3589fe0846f9.js"
    }; /*]]>*/</script>
<script>/*<![CDATA[*/ !function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","https://c.amazon-adsystem.com/aax2/apstag.js");
    apstag.init({
        pubID: '752e9606-96f1-4914-9c3a-704ce3f96f2f',
        adServer: 'googletag',
        simplerGPT: true
    }); /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '26253285/Editorial_728*90';
            
                gptAdSlots['ad-638026'] = googletag.defineSlot(adUnit, [728,90], 'ad-638026').setCollapseEmptyDiv(true).addService(googletag.pubads());
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '26253285/Inskin1x1';
            
                gptAdSlots['ad-981235'] = googletag.defineSlot(adUnit, [1,1], 'ad-981235').setCollapseEmptyDiv(true).addService(googletag.pubads());
    });
 /*]]>*/</script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/sms-link.8eefede3265fd6c6de07bc0cb5f3f779.js"></script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/shared-content/art/tncms/templates/libraries/flex/components/asset/resources/scripts/tnt.nextPrev.f1660ccf5d097410b8b72737d216878c.js"></script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '26253285/MobileHome(02)300x250P1';
            var mapping = googletag.sizeMapping().addSize([320, 0], [300,250]).addSize([768, 0], [300,250]).addSize([992, 0], []).addSize([1200, 0], []).build();
                gptAdSlots['ad-637729'] = googletag.defineSlot(adUnit, [300,250], 'ad-637729').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/26253285/trinidadexpress.com/opinion/editorials';
            var mapping = googletag.sizeMapping().addSize([320, 0], []).addSize([768, 0], []).addSize([992, 0], [300,250]).addSize([1200, 0], [300,250]).build();
                gptAdSlots['ad-631850'] = googletag.defineSlot(adUnit, [300,250], 'ad-631850').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-631850'].setTargeting('pos', ['block-rail-top']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/26253285/trinidadexpress.com/opinion/editorials';
            var mapping = googletag.sizeMapping().addSize([320, 0], []).addSize([768, 0], []).addSize([992, 0], [300,600]).addSize([1200, 0], [300,600]).build();
                gptAdSlots['ad-632079'] = googletag.defineSlot(adUnit, [300,600], 'ad-632079').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-632079'].setTargeting('pos', ['block-rail-middle']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/26253285/trinidadexpress.com/opinion/editorials';
            var mapping = googletag.sizeMapping().addSize([320, 0], []).addSize([768, 0], []).addSize([992, 0], [300,250]).addSize([1200, 0], [300,250]).build();
                gptAdSlots['ad-632080'] = googletag.defineSlot(adUnit, [300,250], 'ad-632080').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-632080'].setTargeting('pos', ['block-rail-bottom']);
    });
 /*]]>*/</script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.notify.6e1ca8839e8a715fdecb1c734223823a.js"></script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.notify.panel.1c7debce90f6bd1a3d679d0176d3712a.js"></script>
<script src="https://www.gstatic.com/firebasejs/6.6.2/firebase-app.js" defer="defer"></script>
<script src="https://www.gstatic.com/firebasejs/6.6.2/firebase-messaging.js" defer="defer"></script>
<script src="/shared-content/art/tncms/api/messaging.js" defer="defer"></script>
<script>/*<![CDATA[*/ document.addEventListener('DOMContentLoaded', function() {TNCMS.Messaging.init({messagingSenderId: '524781685020'});TNCMS.Messaging.onMessage(messagingCallback);}); /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '26253285/MobileHome320x50P1';
            var mapping = googletag.sizeMapping().addSize([320, 0], [320,50]).addSize([768, 0], [320,50]).addSize([992, 0], []).addSize([1200, 0], []).build();
                gptAdSlots['ad-637662'] = googletag.defineSlot(adUnit, [320,50], 'ad-637662').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
    });
 /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/tnt.ads.adverts.66a3812a7b5c12fde8cd998fd691ad7d.js"></script>
<script src="/shared-content/art/tncms/tracking.js"></script>
<script>/*<![CDATA[*/ __tnt.recentFive = {
    /*
     * Gets the data stored in 'tnt:recent:five'
     * Returns Array
     */
        get:function(){
            if(window.localStorage && localStorage.getItem('tnt:recent:five')!=null){
                try{ return JSON.parse(localStorage.getItem('tnt:recent:five')); } catch {}
            }

            return [];
        },

    /*
     * Sets the 'tnt:recent:five' localStorage item
     * Returns boolean
     */
        set:function(data){
            if(window.localStorage){
                try{ 
                    localStorage.setItem('tnt:recent:five', JSON.stringify(data));
                    return true;
                } catch {}
            }

            return false;
        },

    /*
     * Adds the most recent item, prunes any duplicates, and trims the array down to 5 items
     * Returns Array on success, false on fail 
     */
        add:function(asset){
            var assets = __tnt.recentFive.get();
            assets.unshift(asset);

            if(assets.length > 1){
                assets = assets.filter(function(item, index, a){ return a.indexOf(item) == index });

                while(assets.length>5){
                    assets.shift();
                }
            }

            if(__tnt.recentFive.set(assets)){ return assets; }
            return false;
        }
    }; /*]]>*/</script>
<script>/*<![CDATA[*/ 

    googletag.cmd.push(function() {
        googletag.pubads().setTargeting('browser', __tnt.client.browser.name);
        if (__tnt.ads.dfp.targeting) {
            for (var k in __tnt.ads.dfp.targeting) {
                if (__tnt.ads.dfp.targeting.hasOwnProperty(k)) {
                    googletag.pubads().setTargeting(k,__tnt.ads.dfp.targeting[k]);
                }
            }
        }
            googletag.pubads().disableInitialLoad();
            googletag.pubads().addEventListener('impressionViewable', function(event) {
                for (var key in gptAdSlots) {
                    if (gptAdSlots[key] === event.slot && __tnt.ads.slots[key]) {
                        if (!__tnt.ads.slots[key].viewableImpression) __tnt.ads.slots[key].viewableImpression = true;
                    }
                }
            });

        googletag.pubads().enableSingleRequest();
        googletag.enableServices();
    });
 /*]]>*/</script>

            
            <title>Grenada, 37  years later | Editorial | trinidadexpress.com</title>
            
    <style>body { background-color: #fcf8f9; color: #000; }a, a:hover, .pagination>li>a, .pagination>li>a:hover, .btn-link, .dropdown-menu>li>a, blockquote, blockquote p, .asset .asset-body blockquote p { color: #000; } #main-body-container .container, #main-body-container .container_fluid, .well-main { background-color: #fcf8f9; } .tnt-content-width-container > * { max-width: 100%; margin-left: auto; margin-right: auto; } #site-navbar-container, #main-navigation { background-color: #e7e7e7; } .fixed-nav #main-navigation { background-color: #e7e7e7 !important; } #site-top-nav-container, #site-top-nav { background-color: #000; } #site-footer-container, #site-footer { background-color: #e7e7e7; color: #000; } .navbar-default .navbar-nav>li>a, .navbar-default .navbar-nav>li>a:hover, .navbar-default .navbar-nav>li>a:focus, .navbar-default .navbar-nav>.open>a, .navbar-default .navbar-nav>.open>a:hover, .navbar-default .navbar-nav>.open>a:focus { color: #000; } .navbar-toggle .icon-bar { background-color: #000 !important; } .navbar-toggle .sr-only-show { color: #000 !important; } #site-top-nav .list-inline>li>a { color: #fff; } .asset .asset-body p, .asset #asset-content p { color: #000; }@media (min-width: 1200px) { .container { width: 100%; } } @media (min-width: 1396px) { .container.has-wallpaper, .has-wallpaper .container, .container { width: 1366px; } } #site-header-container { background-color: #ffffff; }/* full span block region */ #main-top-container.container-fullscreen-region.container-fluid { padding-left: 0px !important; padding-right: 0px !important; }/* full span block region */ #main-top-container.container-fullscreen-region.container-fluid { padding-left: 0px !important; padding-right: 0px !important; }@media (max-width: 991px){ .navbar-default .navbar-nav .open .dropdown-menu>li>a, .navbar-default .navbar-nav .open .dropdown-menu>li>a:hover, .navbar-default .navbar-nav .open .dropdown-menu>li>a:focus { color: #000; } }#site-copyright a, #site-footer a { color: #000; }.nav-tabs>li.active>a, .nav-tabs>li.active>a:hover, .nav-tabs>li.active>a:focus { border-top-color: #AAA; }#site-header-container{ border-bottom: 3px solid #AAA; }#site-footer-container{ border-top: 3px solid #AAA; } .tnt-bg-accent { background-color: #AAA; } a .tnt-caret-down { color: #AAA; } .block-title .block-title-inner { border-color: #AAA; } a.thumbnail:hover, a.thumbnail:focus, a.thumbnail.active { border-color: #AAA; } .form-control:focus { border-bottom-color: #AAA; } /* CSS has moved to Site templates/Global skins/flexsystem/resources/site.css.inc.utl */ </style> <!-- site.css.inc.utl has been included. --> <!-- NOTE: anything in an include file, outside of UTL tags , will be output on the page --> <style>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</style>
    
        <link rel="shortcut icon" type="image/x-icon" href="https://trinidadexpress.com/content/tncms/site/icon.ico" />
    
        <link rel="amphtml" href="https://trinidadexpress.com/opinion/editorials/grenada-37-years-later/article_7e9a8a48-17e2-11eb-bb19-d3db743fecbd.amp.html" />
    
        <link rel="preconnect" href="//www.googletagmanager.com">
    
        <link rel="preconnect" href="//www.google-analytics.com">
    <link rel="alternate" type="application/rss+xml" title="Grenada, 37  years later | Editorial | trinidadexpress.com" href="http://trinidadexpress.com/search/?f=rss&amp;t=article&amp;c=opinion/editorials&amp;l=50&amp;s=start_time&amp;sd=desc" />
    <link rel="canonical" href="https://trinidadexpress.com/opinion/editorials/grenada-37-years-later/article_7e9a8a48-17e2-11eb-bb19-d3db743fecbd.html" />
            <script defer src="https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/fontawesome.edd147e4c2830f416874012247117438.js"></script>
             
 

<script src="//cdn.districtm.ca/merge/merge.v4.2.107581.js"></script>

<script type='text/javascript'>var _sf_startpt=(new Date()).getTime()</script><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
(adsbygoogle = window.adsbygoogle || []).push({
google_ad_client: "ca-pub-4401567382928778",
enable_page_level_ads: true
});
</script><script type="text/javascript" async="async" src="//trinidadexpress-tto-pw.newsmemory.com/?meter&amp;v=0&amp;service=onstop"></script>  
<script type="text/javascript">
document.addEventListener('keydown', function (e) {
   var e = e || window.event;
   var keyCode = (e.which) ? e.which : e.keyCode;
   if(keyCode == 27){
      console.log("ESC key not allowed!");
      return false;
   }
});                 
</script><script type="text/javascript">
window._taboola = window._taboola || [];
_taboola.push({article:'auto'});
!function (e, f, u, i) {
if (!document.getElementById(i)){
e.async = 1;
e.src = u;
e.id = i;
f.parentNode.insertBefore(e, f);
}
}(document.createElement('script'),
document.getElementsByTagName('script')[0],
'//cdn.taboola.com/libtrc/onecaribbeanmedia-network/loader.js',
'tb_loader_script');
if(window.performance && typeof window.performance.mark == 'function')
{window.performance.mark('tbl_ic');}
</script><script type="text/javascript">
$(document).ready(function(){

//$('#main-page-container > section > div.row > div > div > div.panel-footer.user-signup.text-muted > p:nth-child(2)').html('By submitting this form, you agree to our <a href="/site/privacy.html">Privacy Policy</a>');
$(".section-users .panel-footer.user-signup.text-muted").html("Don't have an account?  <a href='https://trinidadexpress.com/users/signup/'>Register here</a>.</br>Do you have an <a href='http://digital.trinidadexpress.com/'>e-paper</a> subscription? <a href='http://digital.trinidadexpress.com/'>Sign in</a>/<a href='http://digital.trinidadexpress.com/'>Register</a> now.");
$(".section-users .user-login-wrapper .panel-heading").html("Got News? Want to share your opinion on other pressing matters with our large, nationwide following? <br>Sign in or create a  Trinidad Express Newspapers account to send us your Stories, News tips,  Feel Good stories, Letters to the Editor and more!");
$(".section-users .user-register-wrapper .panel-heading").html("Got News? Want to share your opinion on other pressing matters with our large, nationwide following? <br>Sign in or create a  Trinidad Express Newspapers account to send us your Stories, News tips,  Feel Good stories, Letters to the Editor and more!");




$('.blox-asset h1.headline span').prepend('<span class="redsquare"></span>');


});

</script>


<div id='woobox-root'></div>
<script>(function(d, s, id) {
var js, fjs = d.getElementsByTagName(s)[0];
if (d.getElementById(id)) return;
js = d.createElement(s); js.id = id;
js.src = "https://woobox.com/js/plugins/woo.js";
fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'woobox-sdk'));</script>
        </head>
        <body class="fluid fixed-scroll-nav app-editorial grid-mobile-pattern blox-asset uuid-7e9a8a48-17e2-11eb-bb19-d3db743fecbd section-opinionsection-editorials type-article infinity-disabled" data-path="/opinion/editorials">
	<script type='text/javascript' src='/shared-content/art/stats/common/tracker.js'></script>
	<script type='text/javascript'>
	<!--
	if (typeof(TNStats_Tracker) !== 'undefined' && typeof(TNTracker) === 'undefined') { TNTracker = new TNStats_Tracker('trinidadexpress.com'); TNTracker.trackPageView(); }
	// -->
	</script>
	<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PDQV3N&tncms.template.version=3.155.0&tncms.page.grid=mobile_pattern&tncms.page.style=default&tncms.page.path=%2Fopinion%2Feditorials&tncms.page.syndicated=false&tncms.page.reaction=false&tncms.page.app=editorial&tncms.page.theme=flex&tncms.page.skin=flex-editorial&tncms.page.http_status=200&tncms.subscription.required=false&tncms.vendor.outbrain=headlines&tncms.vendor.taboola=&tncms.vendor.chartbeat=61692&tncms.system.render_time=234&tncms.client.is_bot=no&tncms.client.is_gdpr=yes&tncms.asset.id=7e9a8a48-17e2-11eb-bb19-d3db743fecbd&tncms.asset.app=editorial&tncms.google.ua=UA-18252895-1&tncms.client.noscript=yes" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><div id="fb-root"></div>
        
        
        
        <script>
            $(function(){
                var bloxServiceIDs = [];
                var bloxUserServiceIds = [];
                var dataLayer = window.dataLayer || [];

                

                if (__tnt.user.services){
                    var bloxUserServiceIDs = __tnt.user.services.replace('%2C',',').split(',');
                }

                // GTM tncms.subscription.paid_access_service_ids
                if(bloxServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'access_service_ids':bloxServiceIDs.toString()}}});
                }

                // GTM tncms.subscrption.user_service_ids
                if(bloxUserServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'user_service_ids':bloxUserServiceIDs.toString()}}});
                }
            });
        </script>
        
        <div id="site-container"><div id="asset-admin-bar" class="asset-edit-bar hidden-print">
                <div class="asset-edit-icon"><i class="fas tnt-lock-open tnt-fw"></i></div>
                <div class="asset-edit-message">You have permission to edit this article.</div>
                <div class="asset-edit-btns">
                    <a class="btn btn-primary btn-sm" href="https://trinidadexpress.com/tncms/admin/editorial-asset/?edit=7e9a8a48-17e2-11eb-bb19-d3db743fecbd"><i class="fas tnt-pencil-alt tnt-fw"></i> Edit</a>
                    <button class="asset-edit-close btn btn-link btn-sm"><i class="fas tnt-times"></i><span class="sr-only">Close</span></button>
                </div>
            </div>
        

    
        
            <aside class="hidden-print offcanvas-drawer offcanvas-drawer-left">
                <div id="tncms-region-mobile-nav-top-left-region" class="tncms-region "><div id="tncms-block-615249" class="tncms-block site-brand-mark"><section id="block-615249" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow" >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/content/tncms/custom/image/d5ad6b86-10e0-11e8-9148-8bf3c8c24ebf.png" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                alt=""></a></div></section></div><div id="tncms-block-615299" class="tncms-block site-follow-us"><div class="follow-links-615299 default">
    
    <section id="block-615299" class="block emphasis-h3   " ><ul class="list-inline">
        
            <li>
                <a href="https://www.facebook.com/ExpressNewspapers" title="Facebook" target="_blank" rel="noopener" class="btn btn-xs btn-link fb">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href="http://twitter.com/expressupdates/" title="Twitter" target="_blank" rel="noopener" class="btn btn-xs btn-link tw">
                    <i class="fab tnt-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
        
        
        
            <li>
                <a href="https://www.instagram.com/trinidadexpress/" title="Instagram" target="_blank" rel="noopener" class="btn btn-xs btn-link is">
                    <i class="fab tnt-instagram"></i>
                    <span class="sr-only">Instagram</span>
                </a>
            </li>
        
        
        
        
        
        
            <li>
                <a href="http://webmaster@trinidadexpress.com" title="Email" target="_blank" rel="noopener" class="btn btn-xs btn-link em">
                    <i class="fas tnt-envelope"></i>
                    <span class="sr-only">Email</span>
                </a>
            </li>
        
        
        
            <li>
                <a href="http://bit.ly/ExpressiOSApp" title="iOS App" target="_blank" rel="noopener" class="btn btn-xs btn-link io">
                    <i class="fab tnt-app-store-ios"></i>
                    <span class="sr-only">iOS App</span>
                </a>
            </li>
        
        
            <li>
                <a href="http://bit.ly/ExpressAndroidApp" title="Google Playstore App" target="_blank" rel="noopener" class="btn btn-xs btn-link ad">
                    <i class="fab tnt-google-play"></i>
                    <span class="sr-only">Android App</span>
                </a>
            </li>
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://trinidadexpress.com",
  "sameAs" : ["https://www.facebook.com/ExpressNewspapers","http://twitter.com/expressupdates/","https://www.instagram.com/trinidadexpress/","http://webmaster@trinidadexpress.com","http://bit.ly/ExpressiOSApp","http://bit.ly/ExpressAndroidApp"]
}
</script>
<div class="clearfix"></div></div><div id="tncms-block-632037" class="tncms-block"><div class="user-controls menu-nav-subscribe no-service">
<a href="http://digital.trinidadexpress.com/" class="btn btn-default btn-block lee-track-menu-nav" style="color:#333;text-shadow:none;">Subscribe to E-paper</a>
</div></div><div id="tncms-block-615302" class="tncms-block"><div id="user-controls-615302" class="user-controls show-onload clearfix default"><div class="not-logged-in">
        <ul class="list-inline"><li><a href="http://trinidadexpress-tto.newsmemory.com/?purchase" target="_blank" class="btn btn-link btn-sm user-control-link" rel="nofollow">Sign Up</a></li><li>
                    <a href="http://trinidadexpress-tto.newsmemory.com/" class="btn btn-primary btn-sm login-btn user-control-link" rel="nofollow">
                        Log In
                    </a></li>
        </ul>
    </div>

    <div class="logged-in">
        
        
            <div class="hide show-offcanvas">
                <ul class="list-inline">
                    <li><a href="https://trinidadexpress.com/users/admin/" class="btn btn-primary btn-sm login-btn user-control-link">Dashboard</a></li>
                    <li> <a class="btn btn-link btn-sm user-control-link" onclick="jQuery('#user-logout-form-615302').submit(); return false;" rel="nofollow"> Logout</a></li>
                </ul>
            </div>
        
        <ul class="hide-offcanvas list-inline">
            <li class="dropdown pull-right">
                
                <div class="dropdown-toggle btn btn-link btn-sm user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><div class="tn-user-avatar pull-left"><!-- user avatar --></div><span class="tn-user-screenname pull-left"></span><b class="caret user-control-link"></b>
                </div>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li><a href="https://trinidadexpress.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li><a class="tn-user-profile-url" href="" data-app="https://trinidadexpress.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li><a href="https://trinidadexpress.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="presentation" class="divider"></li>
                    <li><a class="logout-btn" onclick="jQuery('#user-logout-form-615302').submit(); return false;" rel="nofollow"><i class="fas tnt-power-off tnt-fw"></i> Logout</a></li>
                </ul>
            </li>
        </ul>
    </div>
</div>

<form method="post" action="https://trinidadexpress.com/users/logout/" id="user-logout-form-615302"><input type="hidden" name="referer_url" value="https://trinidadexpress.com/opinion/editorials/grenada-37-years-later/article_7e9a8a48-17e2-11eb-bb19-d3db743fecbd.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div><div id="tncms-block-615290" class="tncms-block site-nav-sections-header"><section id="block-615290" class="block emphasis-h4   " ><div class="clearfix">
        <ul class="list-inline block-links pos-top ">
            
                
                    <li><a href="/site/contact.html" class="">Contact Us</a></li>
                
                    <li><a href="/site/" class="">Customer Service</a></li>
                
            
            
        </ul></div></section></div></div>
                <div id="tncms-region-nav-mobile-nav-left" class="tncms-region-nav"><div id="mobile-nav-left_menu" class="panel-group nav navbar-nav" role="tablist"><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/coronavirus/"  class="nav-link tnt-section-coronavirus">Coronavirus</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-2" data-target="#mobile-nav-left_menu-child-2">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/opinion/"  class="nav-link tnt-section-opinion">Opinion</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-2" class="collapse nav navbar-nav"><li>
                                    <a href="/opinion/columnists/"  class="nav-link tnt-section-columnists">Columnists</a>
                                </li><li>
                                    <a href="/opinion/editorials/"  class="nav-link tnt-section-editorials">Editorials</a>
                                </li><li>
                                    <a href="/opinion/letters/"  class="nav-link tnt-section-letters-to-the-editor">Letters to the Editor</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/press-releases/"  class="nav-link tnt-section-press-releases">Press Releases</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="https://trinidadexpress.com/special-report/"  target="_blank" rel="noopener" class="nav-link tnt-section-special-report">Special Report</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/multimedia/videos/"  class="nav-link tnt-section-express-tv">Express TV</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/multimedia/onpoint/"  class="nav-link tnt-section-on-point">On Point</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/special/ioy/"  class="nav-link tnt-section-individual-of-the-year">Individual of the Year</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/multimedia/photos/"  class="nav-link tnt-section-photo-gallery">Photo Gallery</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/multimedia/videos/"  class="nav-link tnt-section-videos">Videos</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-10" data-target="#mobile-nav-left_menu-child-10">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a   class="nav-link tnt-section-special">Special</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-10" class="collapse nav navbar-nav"><li>
                                    <a href="/onpoint/"  class="nav-link tnt-section-onpoint-trinidad-express-digital-series">OnPoint: Trinidad Express Digital Series</a>
                                </li><li>
                                    <a href="/news/interactive/budget-2021/"  class="nav-link tnt-section-budget-day-20202021">Budget Day 2020/2021</a>
                                </li><li>
                                    <a href="/opposition2021/"  class="nav-link tnt-section-opposition2021">Opposition2021</a>
                                </li><li>
                                    <a href="https://bit.ly/ExpressElectionCentral"  target="_blank" rel="noopener" class="nav-link tnt-section-election-central-2020">Election Central 2020</a>
                                </li><li>
                                    <a href="https://www.trinidadexpress.com/budget2020"  target="_blank" rel="noopener" class="nav-link tnt-section-budget-20192020">Budget 2019/2020</a>
                                </li><li>
                                    <a href="https://trinidadexpress.com/news/interactive/opposition-2020/"  target="_blank" rel="noopener" class="nav-link tnt-section-opposition-budget-response-2020">Opposition Budget Response 2020</a>
                                </li><li>
                                    <a href="https://www.trinidadexpress.com/budget"  target="_blank" rel="noopener" class="nav-link tnt-section-budget-20182019">Budget 2018/2019</a>
                                </li><li>
                                    <a href="/sks/"  class="nav-link tnt-section-someone-knows-something-sks">Someone Knows Something (SKS)</a>
                                </li></ul></div></div></div>
                
                
                <div id="tncms-region-mobile-nav-bottom-left-region" class="tncms-region "></div>
            </aside>
        
        

        <div class="offcanvas-inner">
            <div class="offcanvas-close-btn"></div>
    

    

    <div id="tncms-region-global-skyline" class="tncms-region "></div>
    

    
        <div id="site-top-nav-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-top-nav" class="container_fluid">
                <div class="row">
                    <div id="topbar-col-one" class="col-md-6 col-sm-6"><div id="tncms-region-topbar-col-one" class="tncms-region "><div id="tncms-block-632047" class="tncms-block"><title>HTML div</title>

<div style="width: 100; float:left; height:60px; margin:0px">
<div id="google_translate_element"></div>

<script type="text/javascript">
function googleTranslateElementInit() {
  new google.translate.TranslateElement({pageLanguage: 'en', layout: google.translate.TranslateElement.InlineLayout.SIMPLE}, 'google_translate_element');
}
</script><script type="text/javascript" src="//translate.google.com/translate_a/element.js?cb=googleTranslateElementInit"></script>
</div>


<div style="width: 100; float:left; height:60px; margin:0px">
<div class="header-sub">  <a href="http://digital.trinidadexpress.com/">Get your Express Subscription  starting at <span><b>$9USD</b> for 1 Month <i class="fa fa-angle-double-right" aria-hidden="true"></i></span></a>
</div>
</div>

</div></div></div>
    <div id="topbar-col-two" class="col-md-6 col-sm-6"><div id="tncms-region-topbar-col-two" class="tncms-region "><div id="tncms-block-828277" class="tncms-block"><div style="margin-top: 5px;" class="ta_account_button btn btn-danger btn-sm login-btn user-control-link pull-right" onclick="ta_account()">Log In</div></div><div id="tncms-block-812119" class="tncms-block"><div id="notification-button-812119" class="notification-button stuck" data-control="notification" data-id="812119" data-tooltip="Get Trinidad Express News alerts as it happens. Click &quot;Allow&quot;  in Chrome, &quot;Yes&quot; in Edge browser. You can always opt out at any time" data-tooltip-placement="right" style="display:none;">
            <span class="badge-dot tnt-bg-accent" style="display:none;"></span>
            <i class="fas tnt-bell"></i>
        </div></div></div></div>
                </div>
            </header>
        </div>
    

    
        <div id="site-header-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-header" class="container_fluid" role="banner">
                
                <div class="row">
                    <div id="masthead-full-top" class="col-lg-12"><div id="tncms-region-masthead-full-top" class="tncms-region "><div id="tncms-block-637705" class="tncms-block"><script>
<!--
function timedRefresh(timeoutPeriod) {
	setTimeout("location.reload(true);",timeoutPeriod);
}

window.onload = timedRefresh(300000);

//   -->
</script></div><div id="tncms-block-638026" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-638026" class="tnt-ads dfp-ad" data-always-load="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-638026');
                        
                });
            </script>
        </div>
    </div>
</div></div></div>
                </div>
                <div class="row">
                    
                    <div id="masthead-col-one" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-one" class="tncms-region "></div></div>
    <div id="masthead-col-two" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-two" class="tncms-region "><div id="tncms-block-981235" class="tncms-block no-bottom-margin"><div class="tnt-ads-container text-center  " >
        <div id="ad-981235" class="tnt-ads dfp-ad" data-always-load="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-981235');
                        
                });
            </script>
        </div>
    </div>
</div></div></div>
    <div id="masthead-col-three" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-three" class="tncms-region "></div></div>
                </div>
                <div class="row">
                    <div id="masthead-full-bottom" class="col-lg-12"><div id="tncms-region-masthead-full-bottom" class="tncms-region "></div></div>
                </div>
                
            </header>
        </div>
    

    
    
        <div id="site-navbar-container" class="hidden-print affix-top">
            
            <nav id="main-navigation" class="navbar yamm navbar-default container_fluid navbar-static">
                
                
                <div class="navbar-header">
                    
                    
                        <button type="button" class=" hamburger-desktop fluid-header navbar-toggle pull-left" data-toggle="offcanvas" data-target="left">
                            <span class="sr-only">Toggle navigation</span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                            <span class="visible-lg visible-md sr-only-show">Menu</span>
                        </button>
                    
                    

                    
                        <div class="navbar-brand hidden-md hidden-lg pos_left">
                            
                                <div id="tncms-region-main-nav-brand" class="tncms-region "><div id="tncms-block-615294" class="tncms-block weeklogo"><section id="block-615294" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow" >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/content/tncms/custom/image/fa290656-b16e-11ea-8535-b7f60b9f79d4.png?resize=200%2C53 200w, https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/content/tncms/custom/image/fa290656-b16e-11ea-8535-b7f60b9f79d4.png?resize=300%2C80 300w, https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/content/tncms/custom/image/fa290656-b16e-11ea-8535-b7f60b9f79d4.png?resize=400%2C107 400w, https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/content/tncms/custom/image/fa290656-b16e-11ea-8535-b7f60b9f79d4.png?resize=540%2C144 540w, https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/content/tncms/custom/image/fa290656-b16e-11ea-8535-b7f60b9f79d4.png 881w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                alt="Daily Express/ Trinidad Express Newspaper"></a></div></section></div><div id="tncms-block-632167" class="tncms-block satlogo"><section id="block-632167" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow" >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/content/tncms/custom/image/fee104e6-b16e-11ea-8535-3f978f102847.png?resize=200%2C53 200w, https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/content/tncms/custom/image/fee104e6-b16e-11ea-8535-3f978f102847.png?resize=300%2C80 300w, https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/content/tncms/custom/image/fee104e6-b16e-11ea-8535-3f978f102847.png?resize=400%2C107 400w, https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/content/tncms/custom/image/fee104e6-b16e-11ea-8535-3f978f102847.png?resize=540%2C144 540w, https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/content/tncms/custom/image/fee104e6-b16e-11ea-8535-3f978f102847.png 881w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                alt="Saturday Express/ Trinidad Express Newspaper"></a></div></section></div><div id="tncms-block-632169" class="tncms-block sunlogo"><section id="block-632169" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow" >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/content/tncms/custom/image/034613d2-b16f-11ea-8535-2b63a75346f0.png?resize=200%2C53 200w, https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/content/tncms/custom/image/034613d2-b16f-11ea-8535-2b63a75346f0.png?resize=300%2C80 300w, https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/content/tncms/custom/image/034613d2-b16f-11ea-8535-2b63a75346f0.png?resize=400%2C107 400w, https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/content/tncms/custom/image/034613d2-b16f-11ea-8535-2b63a75346f0.png?resize=540%2C144 540w, https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/content/tncms/custom/image/034613d2-b16f-11ea-8535-2b63a75346f0.png 881w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                alt="Sunday Express/ Trinidad Express Newspaper"></a></div></section></div></div>
                            
                        </div>
                    

                    
                </div>

                
                    <div id="navbar-collapse" class="navbar-collapse collapse">
                        
                            <div class="pull-right">
                                <div id="tncms-region-main-nav-right-region" class="tncms-region "><div id="tncms-block-615297" class="tncms-block"><ul id="site-search-615297-dropdown" class="hidden-print nav navbar-nav navbar-right site-search-full">
        <li class="search-form-dropdown dropdown yamm-fw">
            <a  onclick="javascript:void(0); return false;"  class="dropdown-toggle" data-hover="dropdown" data-hover-delay="250" data-toggle="dropdown"><span class="fas tnt-search"></span></a>
            <ul class="dropdown-menu">
                <li><form id="site-search-615297" action="/search/" method="GET" class="yamm-content">
    <input type="hidden" name="l" value="25">
    
        
        <input type="hidden" name="sort" value="relevance">
    
    
    
    
    <input type="hidden" name="f" value="html">
    
        
        <input type="hidden" name="t" value="article,video,youtube,collection">
    
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div class="site-search-form input-group pull-right input-group-sm ">
        <input id="site-search-615297-term" name="q" title="Site Search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-615297-btn" class="btn btn-primary" aria-label="Submit Site Search" type="submit">
                
	                <span class="hidden-xl hidden-lg hidden-md fas tnt-search"></span>
	                <span class="hidden-xs hidden-sm">Search</span>
                
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form></ul>
        </li>
    </ul>
 

<script>
    $('#site-search-615297-btn').on(__tnt.client.clickEvent, function(){
        $('#site-search-615297').submit();
        return false;
    });

    $('#site-search-615297').on('submit', function(){
        // Filter query
        var sQueryFiltered = $("#site-search-615297 input[name=q]").val().replace(/\?/g, '');
    $("#site-search-615297 input[name=q]").val( sQueryFiltered );

        if( $('#site-search-615297-term').val() ){
            return true;
        }else{
            return false;
        }
    });</script>
</div></div>
                                
                            </div>
                        
                        <div class="navbar-left">
                            <div id="tncms-region-nav-main-nav" class="tncms-region-nav"><ul id="main-nav_menu" class="nav navbar-nav"><li>
                <a class="nav-link nav-home  tnt-section-home"  href="/" >
                    <span class="nav-icon fas tnt-home tnt-fw"></span> <span class="nav-label">Home</span>
                </a></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-news"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/news/" >
                    <span class="nav-label">News</span>
                </a><ul id="main-nav_menu-child-2" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-2020-elections"  href="/elections/" >
                    <span class="nav-label">2020 Elections </span>
                </a></li><li>
                <a class="nav-link  tnt-section-special-report"  href="https://trinidadexpress.com/special-report"  target="_blank" rel="noopener">
                    <span class="nav-label">Special Report</span>
                </a></li><li>
                <a class="nav-link  tnt-section-local-news"  href="/news/local/" >
                    <span class="nav-label">Local News</span>
                </a></li><li>
                <a class="nav-link  tnt-section-news-extra"  href="/newsextra/" >
                    <span class="nav-label">News Extra</span>
                </a></li><li>
                <a class="nav-link  tnt-section-regional-news"  href="/news/regional" >
                    <span class="nav-label">Regional News</span>
                </a></li><li>
                <a class="nav-link  tnt-section-world-news"  href="/news/world/" >
                    <span class="nav-label">World News</span>
                </a></li><li>
                <a class="nav-link  tnt-section-features"  href="/features/" >
                    <span class="nav-label">Features</span>
                </a></li><li>
                <a class="nav-link  tnt-section-opinion"  href="/opinion/" >
                    <span class="nav-label">Opinion</span>
                </a></li><li>
                <a class="nav-link  tnt-section-tech"  href="/tech" >
                    <span class="nav-label">Tech</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-sports"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/sports/" >
                    <span class="nav-label">Sports</span>
                </a><ul id="main-nav_menu-child-3" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-local-sports"  href="/sports/local/" >
                    <span class="nav-label">Local Sports</span>
                </a></li><li>
                <a class="nav-link  tnt-section-regional-sports"  href="/sports/regional/" >
                    <span class="nav-label">Regional Sports</span>
                </a></li><li>
                <a class="nav-link  tnt-section-world-sports"  href="/sports/world/" >
                    <span class="nav-label">World Sports</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-business"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/business/" >
                    <span class="nav-label">Business</span>
                </a><ul id="main-nav_menu-child-4" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-local-business"  href="/business/local/" >
                    <span class="nav-label">Local Business</span>
                </a></li><li>
                <a class="nav-link  tnt-section-regional-business"  href="/business/regional/" >
                    <span class="nav-label">Regional Business</span>
                </a></li><li>
                <a class="nav-link  tnt-section-world-business"  href="/business/world/" >
                    <span class="nav-label">World Business</span>
                </a></li></ul></li><li>
                <a class="nav-link nav-home  tnt-section-daily-express"  href="/" >
                    <span class="nav-icon fas tnt-home tnt-fw"></span> <span class="nav-label">Daily Express</span>
                </a></li><li>
                <a class="nav-link  tnt-section-e-paper"  href="http://digital.trinidadexpress.com/"  target="_blank" rel="noopener">
                    <span class="nav-label">e-Paper</span>
                </a></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-classifieds"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="https://expressclassifiedstt.com"  target="_blank" rel="noopener">
                    <span class="nav-label">Classifieds</span>
                </a><ul id="main-nav_menu-child-7" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-place-an-ad"  href="https://cas.trinidadexpress.com/"  target="_blank" rel="noopener">
                    <span class="nav-label">Place An Ad</span>
                </a></li></ul></li><li>
                <a class="nav-link  tnt-section-ccntv6"  href="https://www.tv6tnt.com/"  target="_blank" rel="noopener">
                    <span class="nav-label">CCNTV6</span>
                </a></li></ul></div>
                        </div>
                    </div>
                

                
            </nav>
            
        <div class="visible-xs pull-right article-share-nav" style="background-color: #e7e7e7">
            <span>Share This <i class="fas tnt-arrow-right"></i></span>
            <ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Ftrinidadexpress.com%2Fopinion%2Feditorials%2Fgrenada-37-years-later%2Farticle_7e9a8a48-17e2-11eb-bb19-d3db743fecbd.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/opinion/editorials/grenada-37-years-later/article_7e9a8a48-17e2-11eb-bb19-d3db743fecbd.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"7e9a8a48-17e2-11eb-bb19-d3db743fecbd"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Grenada%2C%2037%20%20years%20later&via=expressupdates&url=https%3A%2F%2Ftrinidadexpress.com%2Fopinion%2Feditorials%2Fgrenada-37-years-later%2Farticle_7e9a8a48-17e2-11eb-bb19-d3db743fecbd.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/opinion/editorials/grenada-37-years-later/article_7e9a8a48-17e2-11eb-bb19-d3db743fecbd.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"7e9a8a48-17e2-11eb-bb19-d3db743fecbd"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://trinidadexpress.com/opinion/editorials/grenada-37-years-later/article_7e9a8a48-17e2-11eb-bb19-d3db743fecbd.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/opinion/editorials/grenada-37-years-later/article_7e9a8a48-17e2-11eb-bb19-d3db743fecbd.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"7e9a8a48-17e2-11eb-bb19-d3db743fecbd"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20trinidadexpress.com/tncms/asset/editorial/7e9a8a48-17e2-11eb-bb19-d3db743fecbd" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"7e9a8a48-17e2-11eb-bb19-d3db743fecbd"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BTrinidad%20Express%20Newspapers%5D%20Grenada%2C%2037%20%20years%20later&body=https%3A%2F%2Ftrinidadexpress.com%2Fopinion%2Feditorials%2Fgrenada-37-years-later%2Farticle_7e9a8a48-17e2-11eb-bb19-d3db743fecbd.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"7e9a8a48-17e2-11eb-bb19-d3db743fecbd"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li></ul>
        </div>
            
        </div>
        
            
                
            
        
    
    
    <div id="main-body-container">
    <section id="main-top-container" class="container-fullscreen-region container-fluid">
          

<div class="col-md-12"><div id="tncms-region-custom-breaking-region" class="tncms-region "><div id="tncms-block-615288" class="tncms-block breaking-box text-center section-no-margin"></div></div></div>


        <div class="fullscreen-region"><div id="tncms-region-global-container-top-fullscreen" class="tncms-region "></div></div>
    </section>
    <section id="main-page-container" class="container_fluid">
        <div class="row">
                <div id="asset-container-top" class="col-md-12"><div id="tncms-region-asset_container_top" class="tncms-region hidden-print"><div id="tncms-block-636470" class="tncms-block"><section id="block-636470" class="block emphasis-   " >
        <ol class="breadcrumb  " itemscope itemtype="https://schema.org/BreadcrumbList"><li itemprop="itemListElement" itemscope
      itemtype="https://schema.org/ListItem">
                    <a href="/" itemprop="item">
                        <span itemprop="name">Home</span>
                    </a>
                    <meta itemprop="position" content="1" />
                </li><li itemprop="itemListElement" itemscope
      itemtype="https://schema.org/ListItem">
                    <a href="/opinion/" itemprop="item">
                        <span itemprop="name">Opinion</span>
                    </a>
                    <meta itemprop="position" content="2" />
                </li><li class="active" itemprop="itemListElement" itemscope
      itemtype="https://schema.org/ListItem">
                    <a href="/opinion/editorials/" itemprop="item">
                        <span itemprop="name">Editorial</span>
                    </a>
                    <meta itemprop="position" content="3" />
                </li></ol></section></div></div></div>
            
            <div class="col-md-12"><div id="tncms-region-global-container-top" class="tncms-region "></div></div>
        </div><div id="modal-image-410f1484-2337-11e8-bb31-277e215e09e6" class="modal fullscreen in modal-image image-default modal-410f1484-2337-11e8-bb31-277e215e09e6" role="dialog" aria-hidden="true" data-lazy-content>
        <template>
            <button type="button" class="close hidden-print" data-dismiss="modal">
                <span aria-hidden="true" class="control-left fas tnt-times-circle"></span>
                <span class="sr-only">Close</span>
            </button>
            <div class="modal-dialog modal-lg">
                <div class="modal-content">
                    <div class="modal-body">
                        <div class="modal-image-container"><figure class="photo layout-horizontal letterbox-style-default">
            <div class="image" 
                >
                
                
                
                
        <img
                    src="https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/content/tncms/assets/v3/editorial/4/10/410f1484-2337-11e8-bb31-277e215e09e6/5aa1e025dfd39.image.jpg?resize=400%2C307"
                    srcset="https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/content/tncms/assets/v3/editorial/4/10/410f1484-2337-11e8-bb31-277e215e09e6/5aa1e025dfd39.image.jpg?resize=200%2C154 200w, https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/content/tncms/assets/v3/editorial/4/10/410f1484-2337-11e8-bb31-277e215e09e6/5aa1e025dfd39.image.jpg?resize=300%2C231 300w, https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/content/tncms/assets/v3/editorial/4/10/410f1484-2337-11e8-bb31-277e215e09e6/5aa1e025dfd39.image.jpg?resize=400%2C307 400w, https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/content/tncms/assets/v3/editorial/4/10/410f1484-2337-11e8-bb31-277e215e09e6/5aa1e025dfd39.image.jpg?resize=540%2C415 540w, https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/content/tncms/assets/v3/editorial/4/10/410f1484-2337-11e8-bb31-277e215e09e6/5aa1e025dfd39.image.jpg?resize=730%2C561 881w"
                    sizes="100vw"
                    width="730"
                    height="561"
                    alt="Express Editorial : Daily"
                    class="img-responsive true-size default" />
                
                
            </div>
            
                
                
            
        </figure></div>
                    </div>
                </div>
            </div>
            <div class="modal-caption">
        <div class="caption-container">
                <span class="pull-right photo-carousel-caption-toggle" data-toggle="collapse" data-instance="#carousel-modal-image-410f1484-2337-11e8-bb31-277e215e09e6" data-target=".caption-inner-modal-image-410f1484-2337-11e8-bb31-277e215e09e6">
                    <i class="fas tnt-minus-circle"></i>
                </span>
            <div class="caption-inner-modal-image-410f1484-2337-11e8-bb31-277e215e09e6 collapse in"><div class="caption-text"></div><div class="card-meta">
                        <ul class="list-inline">
                            
                                
                                
                            
                            
                            
                        </ul>
                    </div>
                    <div class="photo-share">
                        <ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Ftrinidadexpress.com%2Fexpress-editorial-daily%2Fimage_410f1484-2337-11e8-bb31-277e215e09e6.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/express-editorial-daily/image_410f1484-2337-11e8-bb31-277e215e09e6.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"410f1484-2337-11e8-bb31-277e215e09e6"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Express%20Editorial%20%3A%20Daily&via=expressupdates&url=https%3A%2F%2Ftrinidadexpress.com%2Fexpress-editorial-daily%2Fimage_410f1484-2337-11e8-bb31-277e215e09e6.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/express-editorial-daily/image_410f1484-2337-11e8-bb31-277e215e09e6.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"410f1484-2337-11e8-bb31-277e215e09e6"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://trinidadexpress.com/express-editorial-daily/image_410f1484-2337-11e8-bb31-277e215e09e6.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/express-editorial-daily/image_410f1484-2337-11e8-bb31-277e215e09e6.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"410f1484-2337-11e8-bb31-277e215e09e6"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20trinidadexpress.com/tncms/asset/editorial/410f1484-2337-11e8-bb31-277e215e09e6" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"410f1484-2337-11e8-bb31-277e215e09e6"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BTrinidad%20Express%20Newspapers%5D%20Express%20Editorial%20%3A%20Daily&body=https%3A%2F%2Ftrinidadexpress.com%2Fexpress-editorial-daily%2Fimage_410f1484-2337-11e8-bb31-277e215e09e6.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"410f1484-2337-11e8-bb31-277e215e09e6"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/express-editorial-daily/image_410f1484-2337-11e8-bb31-277e215e09e6.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"410f1484-2337-11e8-bb31-277e215e09e6"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-410f1484-2337-11e8-bb31-277e215e09e6-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="410f1484-2337-11e8-bb31-277e215e09e6" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="410f1484-2337-11e8-bb31-277e215e09e6" class="save-list-410f1484-2337-11e8-bb31-277e215e09e6-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="410f1484-2337-11e8-bb31-277e215e09e6" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="images" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>

                    </div>
            </div>
        </div>
    </div>
            <style>
                #modal-image-410f1484-2337-11e8-bb31-277e215e09e6 img { max-height: 561px; }
            </style>
        </template>
    </div><article itemscope itemtype="https://schema.org/Article" id="asset-7e9a8a48-17e2-11eb-bb19-d3db743fecbd" class="asset article-personality" data-url="https://trinidadexpress.com/opinion/editorials/grenada-37-years-later/article_7e9a8a48-17e2-11eb-bb19-d3db743fecbd.html">
    <span itemscope itemtype="http://schema.org/SpeakableSpecification">
        <meta itemprop="cssSelector" content=".asset-header .headline" />
        <meta itemprop="cssSelector" content=".asset-content p:first-of-type" />
    </span><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
        <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="url" content="https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/content/tncms/assets/v3/editorial/4/10/410f1484-2337-11e8-bb31-277e215e09e6/5aa1e025dfd39.image.jpg?resize=730%2C561">
            <meta itemprop="width" content="730">
            <meta itemprop="height" content="561">
        </div>
        <meta itemprop="name" content="trinidadexpress.com">
    </div>
    <link itemprop="mainEntityOfPage" href="https://trinidadexpress.com/opinion/editorials/grenada-37-years-later/article_7e9a8a48-17e2-11eb-bb19-d3db743fecbd.html" />
    <style>
                .asset-paging .direction {
                    color: #AAA;
                }
            </style><div class="asset-paging-container hidden-print" data-settings='{"assetType":"article","hasPageBreak":false,"isObit":false,"nextUrl":"https:\/\/trinidadexpress.com\/tncms\/search\/mlt\/?origin=7e9a8a48-17e2-11eb-bb19-d3db743fecbd&app=editorial&preview=1&type=article%2Ccollection%2Cvideo%2Cyoutube","uuid":"7e9a8a48-17e2-11eb-bb19-d3db743fecbd","isFluid":true,"isAdminVenue":false}'>
            <div id="asset-paging-7e9a8a48-17e2-11eb-bb19-d3db743fecbd" class="asset-paging">
                <div id="paging-prev-7e9a8a48-17e2-11eb-bb19-d3db743fecbd" class="paging-link prev offset"></div>
                <div id="paging-next-7e9a8a48-17e2-11eb-bb19-d3db743fecbd" class="paging-link next offset"></div>
                <div class="clearfix"></div>
            </div>
        </div>
        <template id="asset-paging-template">
            <a class="animate arrow text-center">
                <span class=""></span>
                <span class="animate direction hidden-sm hidden-xs text-primary"></span>
            </a>
            <div class="animate item">
                <div class="dismiss" onclick="document.body.classList.add('trigger-disabled'); document.body.classList.remove('trigger-next'); return false;">
                    <span class="tnt-stack" aria-hidden="true">
                        <i class="fas tnt-circle tnt-inverse tnt-stack-1x"></i>
                        <i class="fas tnt-times-circle tnt-stack-1x"></i>
                    </span>
                </div>
                <div class="inner">
                    <a class="overlay">
                        <span class="sr-only"></span>
                    </a>
                    <div class="head text-uppercase">
                        <small></small>
                    </div>
                    <div class="media">
                        <div class="media-body">
                            <h6 class="media-heading"></h6>
                            <p class="hidden-xs"></p>
                        </div>
                    </div>
                    <div class="clearfix"></div>
                </div>
            </div>
        </template><div class="asset-masthead ">
        <header class="asset-header">
    
    <h1 itemprop="headline" class="headline">
        <span>
            
            Grenada, 37  years later
        </span>
    </h1>
    
    <div class="meta">
        <span>
            <ul class="list-inline">
        
        
            <li class="visible-print">
        <time datetime="2020-10-26T19:25:00-04:00" class="tnt-date asset-date text-muted">
            Oct 26, 2020
        </time></li>
            <li class="hidden-print">
        <time datetime="2020-10-26T19:25:00-04:00" class="tnt-date asset-date text-muted">1 hr ago</time></li>
        
        
            <li class="hidden-print"></li>
        
        
            <li class="hidden-print"><div class="time-to-read-wrapper">
               <span class="fas tnt-book"></span>
               <span class="read-time">2 min to read</span>
           </div></li>
        
    </ul>
        </span>
    </div>
    <meta itemprop="dateCreated" content="2020-10-26T19:25:00-04:00">
    <meta itemprop="datePublished" content="2020-10-26T19:25:00-04:00">
    <meta itemprop="dateModified" content="2020-10-26T19:25:00-04:00">
</header>
        
        
            <div class="share-container headline-right pull-right hidden-xs" data-subscription-required-remove>
                <ul class="social-share-links hidden-print list-unstyled stacked icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Ftrinidadexpress.com%2Fopinion%2Feditorials%2Fgrenada-37-years-later%2Farticle_7e9a8a48-17e2-11eb-bb19-d3db743fecbd.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/opinion/editorials/grenada-37-years-later/article_7e9a8a48-17e2-11eb-bb19-d3db743fecbd.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"7e9a8a48-17e2-11eb-bb19-d3db743fecbd"}' >
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Share">
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Grenada%2C%2037%20%20years%20later&via=expressupdates&url=https%3A%2F%2Ftrinidadexpress.com%2Fopinion%2Feditorials%2Fgrenada-37-years-later%2Farticle_7e9a8a48-17e2-11eb-bb19-d3db743fecbd.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/opinion/editorials/grenada-37-years-later/article_7e9a8a48-17e2-11eb-bb19-d3db743fecbd.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"7e9a8a48-17e2-11eb-bb19-d3db743fecbd"}' >
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Tweet">
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://trinidadexpress.com/opinion/editorials/grenada-37-years-later/article_7e9a8a48-17e2-11eb-bb19-d3db743fecbd.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/opinion/editorials/grenada-37-years-later/article_7e9a8a48-17e2-11eb-bb19-d3db743fecbd.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"7e9a8a48-17e2-11eb-bb19-d3db743fecbd"}' >
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="WhatsApp">
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20trinidadexpress.com/tncms/asset/editorial/7e9a8a48-17e2-11eb-bb19-d3db743fecbd" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"7e9a8a48-17e2-11eb-bb19-d3db743fecbd"}'  rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="SMS">
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BTrinidad%20Express%20Newspapers%5D%20Grenada%2C%2037%20%20years%20later&body=https%3A%2F%2Ftrinidadexpress.com%2Fopinion%2Feditorials%2Fgrenada-37-years-later%2Farticle_7e9a8a48-17e2-11eb-bb19-d3db743fecbd.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"7e9a8a48-17e2-11eb-bb19-d3db743fecbd"}'  rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Email">
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li></ul>
            </div>
        
    </div>

    

    <div class="row">
        <div class="main-content col-lg-8 col-md-7 has-sidebar"><div class="main-content-wrap">

            <div id="tncms-region-article_top" class="tncms-region hidden-print"></div>
            
            
            
            <div class="asset-photo card"><figure class="photo layout-horizontal hover-expand letterbox-style-default"><span class="expand hidden-print"
               
               data-toggle="modal"
                
                    data-target=".modal-410f1484-2337-11e8-bb31-277e215e09e6" 
                    >
                       <span class="fas tnt-expand"></span>
                   </span>
            
            <div class="image" 
                 
                    data-toggle="modal" 
                     
                    data-target=".modal-410f1484-2337-11e8-bb31-277e215e09e6" 
                    >
                
                
                
                
        <div itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="width" content="730">
            <meta itemprop="height" content="561">
            <meta itemprop="contentUrl" content="https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/content/tncms/assets/v3/editorial/4/10/410f1484-2337-11e8-bb31-277e215e09e6/5aa1e025dfd39.image.jpg">
            <meta itemprop="url" content="https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/content/tncms/assets/v3/editorial/4/10/410f1484-2337-11e8-bb31-277e215e09e6/5aa1e025dfd39.image.jpg">
        <img
                    src="https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/content/tncms/assets/v3/editorial/4/10/410f1484-2337-11e8-bb31-277e215e09e6/5aa1e025dfd39.image.jpg?resize=400%2C307"
                    srcset="https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/content/tncms/assets/v3/editorial/4/10/410f1484-2337-11e8-bb31-277e215e09e6/5aa1e025dfd39.image.jpg?resize=200%2C154 200w, https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/content/tncms/assets/v3/editorial/4/10/410f1484-2337-11e8-bb31-277e215e09e6/5aa1e025dfd39.image.jpg?resize=300%2C231 300w, https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/content/tncms/assets/v3/editorial/4/10/410f1484-2337-11e8-bb31-277e215e09e6/5aa1e025dfd39.image.jpg?resize=400%2C307 400w, https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/content/tncms/assets/v3/editorial/4/10/410f1484-2337-11e8-bb31-277e215e09e6/5aa1e025dfd39.image.jpg?resize=540%2C415 540w, https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/content/tncms/assets/v3/editorial/4/10/410f1484-2337-11e8-bb31-277e215e09e6/5aa1e025dfd39.image.jpg?resize=730%2C561 881w"
                    sizes="(min-width: 1396px) calc(66.70vw - 60px), 100vw"
                    width="730"
                    height="561"
                    alt="Express Editorial : Daily"
                    class="img-responsive full tnt-restrict-img-410f1484-2337-11e8-bb31-277e215e09e6 default" />
            </div><style>
                .tnt-restrict-img-410f1484-2337-11e8-bb31-277e215e09e6 {
                    max-width: 730px;
                }
            </style>
                
                
            </div>
            
                
                
            
        </figure></div>

            

            <div id="tncms-region-article_top_content" class="tncms-region hidden-print"></div>

            <div id="asset-content" data-asset-uuid="7e9a8a48-17e2-11eb-bb19-d3db743fecbd">
                

                <div class="row">
                    <div class="col-lg-12 col-md-12 col-sm-12" data-subscription-required-class="col-xs-12">
                        
                            
                            <div id="share-left-affix" class="share-container content-left hidden-xs" data-subscription-required-remove><ul class="social-share-links hidden-print list-unstyled stacked icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Ftrinidadexpress.com%2Fopinion%2Feditorials%2Fgrenada-37-years-later%2Farticle_7e9a8a48-17e2-11eb-bb19-d3db743fecbd.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/opinion/editorials/grenada-37-years-later/article_7e9a8a48-17e2-11eb-bb19-d3db743fecbd.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"7e9a8a48-17e2-11eb-bb19-d3db743fecbd"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Grenada%2C%2037%20%20years%20later&via=expressupdates&url=https%3A%2F%2Ftrinidadexpress.com%2Fopinion%2Feditorials%2Fgrenada-37-years-later%2Farticle_7e9a8a48-17e2-11eb-bb19-d3db743fecbd.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/opinion/editorials/grenada-37-years-later/article_7e9a8a48-17e2-11eb-bb19-d3db743fecbd.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"7e9a8a48-17e2-11eb-bb19-d3db743fecbd"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://trinidadexpress.com/opinion/editorials/grenada-37-years-later/article_7e9a8a48-17e2-11eb-bb19-d3db743fecbd.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/opinion/editorials/grenada-37-years-later/article_7e9a8a48-17e2-11eb-bb19-d3db743fecbd.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"7e9a8a48-17e2-11eb-bb19-d3db743fecbd"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20trinidadexpress.com/tncms/asset/editorial/7e9a8a48-17e2-11eb-bb19-d3db743fecbd" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"7e9a8a48-17e2-11eb-bb19-d3db743fecbd"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BTrinidad%20Express%20Newspapers%5D%20Grenada%2C%2037%20%20years%20later&body=https%3A%2F%2Ftrinidadexpress.com%2Fopinion%2Feditorials%2Fgrenada-37-years-later%2Farticle_7e9a8a48-17e2-11eb-bb19-d3db743fecbd.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"7e9a8a48-17e2-11eb-bb19-d3db743fecbd"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/opinion/editorials/grenada-37-years-later/article_7e9a8a48-17e2-11eb-bb19-d3db743fecbd.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"7e9a8a48-17e2-11eb-bb19-d3db743fecbd"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-7e9a8a48-17e2-11eb-bb19-d3db743fecbd-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="7e9a8a48-17e2-11eb-bb19-d3db743fecbd" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="7e9a8a48-17e2-11eb-bb19-d3db743fecbd" class="save-list-7e9a8a48-17e2-11eb-bb19-d3db743fecbd-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="7e9a8a48-17e2-11eb-bb19-d3db743fecbd" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            
                            <script>
                                $(window).load(function() {
                                    window.setTimeout(affixShare, 2000);
                                    function affixShare() {
                                        var sHeight = $('#share-left-affix').outerHeight(true);
                                        var cHeight = $('#share-left-affix').parent().outerHeight(true);
                                        var sTop = $('#share-left-affix').offset().top - 50;
                                        var sBottom = $(document).height() - ($('#share-left-affix').parent().offset().top + cHeight - 50);
                                        if(cHeight > sHeight) {
                                            $('#share-left-affix').affix({
                                                offset: { top: sTop, bottom: sBottom }
                                            });
                                        }
                                    }
                                });
                                $(window).resize(function() {
                                    var sHeight = $('#share-left-affix').outerHeight(true);
                                    var cHeight = $('#share-left-affix').parent().outerHeight(true);
                                    var sTop = $('#share-left-affix').offset().top - 50;
                                    var sBottom = $(document).height() - ($('#share-left-affix').parent().offset().top + $('#share-left-affix').parent().outerHeight(true) - 50);
                                    if(cHeight > sHeight) {
                                        $('#share-left-affix').data('bs.affix').options.offset.top = sTop;
                                        $('#share-left-affix').data('bs.affix').options.offset.bottom = sBottom;
                                    }
                                });
                            </script>
                            
                        

                        <div class="asset-body has-fixed-share" data-subscription-required-class="asset-body">
                            
                                <div class="share-container content-above visible-xs" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Ftrinidadexpress.com%2Fopinion%2Feditorials%2Fgrenada-37-years-later%2Farticle_7e9a8a48-17e2-11eb-bb19-d3db743fecbd.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/opinion/editorials/grenada-37-years-later/article_7e9a8a48-17e2-11eb-bb19-d3db743fecbd.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"7e9a8a48-17e2-11eb-bb19-d3db743fecbd"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Grenada%2C%2037%20%20years%20later&via=expressupdates&url=https%3A%2F%2Ftrinidadexpress.com%2Fopinion%2Feditorials%2Fgrenada-37-years-later%2Farticle_7e9a8a48-17e2-11eb-bb19-d3db743fecbd.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/opinion/editorials/grenada-37-years-later/article_7e9a8a48-17e2-11eb-bb19-d3db743fecbd.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"7e9a8a48-17e2-11eb-bb19-d3db743fecbd"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://trinidadexpress.com/opinion/editorials/grenada-37-years-later/article_7e9a8a48-17e2-11eb-bb19-d3db743fecbd.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/opinion/editorials/grenada-37-years-later/article_7e9a8a48-17e2-11eb-bb19-d3db743fecbd.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"7e9a8a48-17e2-11eb-bb19-d3db743fecbd"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20trinidadexpress.com/tncms/asset/editorial/7e9a8a48-17e2-11eb-bb19-d3db743fecbd" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"7e9a8a48-17e2-11eb-bb19-d3db743fecbd"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BTrinidad%20Express%20Newspapers%5D%20Grenada%2C%2037%20%20years%20later&body=https%3A%2F%2Ftrinidadexpress.com%2Fopinion%2Feditorials%2Fgrenada-37-years-later%2Farticle_7e9a8a48-17e2-11eb-bb19-d3db743fecbd.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"7e9a8a48-17e2-11eb-bb19-d3db743fecbd"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/opinion/editorials/grenada-37-years-later/article_7e9a8a48-17e2-11eb-bb19-d3db743fecbd.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"7e9a8a48-17e2-11eb-bb19-d3db743fecbd"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-7e9a8a48-17e2-11eb-bb19-d3db743fecbd-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="7e9a8a48-17e2-11eb-bb19-d3db743fecbd" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="7e9a8a48-17e2-11eb-bb19-d3db743fecbd" class="save-list-7e9a8a48-17e2-11eb-bb19-d3db743fecbd-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="7e9a8a48-17e2-11eb-bb19-d3db743fecbd" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            
                            
                            <div id="tncms-region-article_body_top" class="tncms-region hidden-print"></div>

                            <div  itemprop="articleBody" class="asset-content  subscriber-premium">
                                <meta itemprop="isAccessibleForFree" content="true"/>
                                
                                
                                <p>CARIBBEAN countries joined with others across the world on Sunday to mark the 37th anniversary of the collapse of a socialist experiment which had been undertaken neighbouring Grenada four and half years earlier, on March 13, 1979.</p><p>This was the date on which a political grouping known as the New Jewel Movement, (NJM) ousted a sitting Prime Minister and took control of the country. With a population less than 100,000 persons at the time, a popular young attorney named Maurice Bishop and a strident young economist named Bernard Coard set themselves up as join leaders of this movement which pushed the population into the embrace of socialist and communist development. Close friends of the movement at the time included the then Jamaican prime minister Michael Manley, Cuba’s Fidel Castro and Daniel Ortega who had taken power in Nicaragua.</p><p>From the beginning, the Government of Trinidad and Tobago, then under the leadership of the late Dr Eric Williams, had been less than enthusiastic over those developments.</p><div id="tncms-region-article_instory_top" class="tncms-region hidden-print"><div id="tncms-block-637729" class="tncms-block grey-ad hidden-md hidden-lg"><div class="tnt-ads-container text-center  " >
        <div id="ad-637729" class="tnt-ads dfp-ad" data-always-load="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-637729');
                        
                });
            </script>
        </div>
    </div>
</div></div><p>Moving ahead with a decidedly socialist, “people’s” agenda, the NJM administration faced enormous internal pressures over an agreement for what had been termed “joint leadership,” between Bishop and Coard. At the same time, it faced increasing pressure from other leaders in the regional integration movement to “regularise” its status by the calling of elections. On top of that, the construction of a new international airport, with significant assistance from other countries in the Communist Bloc, including Cuba and the Soviet Union, attracted significant opposition and negative imaging from others, principally among them the US government, under then president Ronald Reagan.</p><p>It was at the Caricom Heads of Government Conference in Port of Spain in July 1983, under the chairmanship of then-prime minister George Chambers, and under pressure from such leaders as Barbados’ Tom Adams and Jamaica’s Edward Seaga, Bishop announced a decision to hold elections, after the preparation of a suitable new constitution. He announced a decision to appoint two Trinidad and Tobago attorneys, Allan Alexander and Frank Solomon, to undertake that particular assignment. People in the “Spice Island” were also being prepped for celebrations to mark the fifth anniversary of the so-called “Revo” in March 1984. But the pace of those developments was being undermined by increasing internal strife at the top on the issue of “joint leadership.” This led to a river of no return, with the placing of the prime minister under house arrest in September 1983. Those actions led to a massacre in which he and several others of his ardent supporters were lined up and shot at a fort overlooking the capital city, after he was freed from captivity. This was October 19. Six days later, on the urgings of several Caricom leaders, Seaga, Adams and Dominica’s Eugenia Charles prominent among them, the US led an invasion into Grenada on October 25. Ms Charles was at president Reagan’s side at the White House the morning when the invasion was announced. She said it was a decision taken in the interest of the welfare of those she described as Caribbean “kith and kin.” The Government in Trinidad and Tobago did not support this action either, along with several other Caricom members, including Guyana.</p><p>Thirty seven years later, this signal event in modern Caribbean history, remains a subject for continuing study and analysis, with this country’s role and function in it warranting pride of place. This is especially so given the deeply close historical ties between the people of both countries.</p><div id="tncms-region-article_instory_bottom" class="tncms-region hidden-print"></div>
                                <div id="tncms-region-article_bottom_content" class="tncms-region hidden-print"></div>
                                
                            </div>

                            

                            
    


                            
                                <div class="share-container content-below" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Ftrinidadexpress.com%2Fopinion%2Feditorials%2Fgrenada-37-years-later%2Farticle_7e9a8a48-17e2-11eb-bb19-d3db743fecbd.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/opinion/editorials/grenada-37-years-later/article_7e9a8a48-17e2-11eb-bb19-d3db743fecbd.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"7e9a8a48-17e2-11eb-bb19-d3db743fecbd"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Grenada%2C%2037%20%20years%20later&via=expressupdates&url=https%3A%2F%2Ftrinidadexpress.com%2Fopinion%2Feditorials%2Fgrenada-37-years-later%2Farticle_7e9a8a48-17e2-11eb-bb19-d3db743fecbd.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/opinion/editorials/grenada-37-years-later/article_7e9a8a48-17e2-11eb-bb19-d3db743fecbd.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"7e9a8a48-17e2-11eb-bb19-d3db743fecbd"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://trinidadexpress.com/opinion/editorials/grenada-37-years-later/article_7e9a8a48-17e2-11eb-bb19-d3db743fecbd.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/opinion/editorials/grenada-37-years-later/article_7e9a8a48-17e2-11eb-bb19-d3db743fecbd.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"7e9a8a48-17e2-11eb-bb19-d3db743fecbd"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20trinidadexpress.com/tncms/asset/editorial/7e9a8a48-17e2-11eb-bb19-d3db743fecbd" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"7e9a8a48-17e2-11eb-bb19-d3db743fecbd"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BTrinidad%20Express%20Newspapers%5D%20Grenada%2C%2037%20%20years%20later&body=https%3A%2F%2Ftrinidadexpress.com%2Fopinion%2Feditorials%2Fgrenada-37-years-later%2Farticle_7e9a8a48-17e2-11eb-bb19-d3db743fecbd.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"7e9a8a48-17e2-11eb-bb19-d3db743fecbd"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/opinion/editorials/grenada-37-years-later/article_7e9a8a48-17e2-11eb-bb19-d3db743fecbd.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"7e9a8a48-17e2-11eb-bb19-d3db743fecbd"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-7e9a8a48-17e2-11eb-bb19-d3db743fecbd-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="7e9a8a48-17e2-11eb-bb19-d3db743fecbd" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="7e9a8a48-17e2-11eb-bb19-d3db743fecbd" class="save-list-7e9a8a48-17e2-11eb-bb19-d3db743fecbd-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="7e9a8a48-17e2-11eb-bb19-d3db743fecbd" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            
                        </div>
                        
                    </div></div><!-- /asset-content -->

                <div id="asset-below">
                    

                    

                    

                    

                    

                    

                    

                    

                    

                     

                    

                    <div id="tncms-region-article_bottom" class="tncms-region hidden-print"><div id="tncms-block-638668" class="tncms-block"><!--Carambola Script --><img height="0" width="0" alt="" src="//pixel.watch/14ea"><script data-cfasync="false" class="carambola_InContent" type="text/javascript" cbola_wid="0">  
(function (i,d,s,o,m,r,t,l,w,q,y,h,g) {  
var e=d.getElementById(r);if(e===null){  
var t = d.createElement(o); t.src = g; t.id = r; t.setAttribute(m, s);t.async = 1;var n=d.getElementsByTagName(o)[0];n.parentNode.insertBefore(t, n); 
var dt=new Date().getTime();  
try{i[l][w+y](h,i[l][q+y](h)+'&'+dt);}catch(er){i[h]=dt;}  
} else if(typeof i[t]!=='undefined'){i[t]++}  
else{i[t]=1;}  
})(window, document, 'InContent', 'script', 'mediaType', 'carambola_proxy','Cbola_IC','localStorage','set','get','Item','cbolaDt','//route.carambo.la/inimage/getlayer?pid=crbb88&did=110538&wid=0')  
</script></div><div id="tncms-block-726265" class="tncms-block"><div id="taboola-below-article-thumbnails"></div>
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({
    mode: 'alternating-thumbnails-a',
    container: 'taboola-below-article-thumbnails',
    placement: 'Below Article Thumbnails',
    target_type: 'mix'
  });
</script></div><div id="tncms-block-636623" class="tncms-block more-news-headlines-block"><section id="block-636623" class="block emphasis-h3 dark  " ><div class="clearfix">
    
    <div class="block-title title-636623 ">
        <div class="block-title-inner">
            <h3>
                
                RECOMMENDED FOR YOU
                
            </h3>
        </div>
    </div></div><div class="card-grid   card-img-md card-compact">
        
        
            <div class=" row">
        
        <div class=" col-sm-4 ">
                 
                                
                    <article id="card-summary-636623-7e9a8a48-17e2-11eb-bb19-d3db743fecbd" class="tnt-asset-type-article clearfix card summary has-image image-top dark letterbox-style-default  tnt-section-opinion tnt-sub-section-editorials">
            <div class="card-container"><div class="card-image card-image-top">
                        <div class="media-preview-7e9a8a48-17e2-11eb-bb19-d3db743fecbd media-preview article-asset" data-aspect="16:9"><figure class="photo layout-horizontal letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/opinion/editorials/grenada-37-years-later/article_7e9a8a48-17e2-11eb-bb19-d3db743fecbd.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAJCAQAAACRI2S5AAAAEklEQVR42mM8U8+AFzCOKgADAHdUC60wg0dkAAAAAElFTkSuQmCC"
                            alt="Grenada, 37  years later"
                            class="img-responsive lazyload full default"
                            width="730"
                            height="411"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/content/tncms/assets/v3/editorial/4/10/410f1484-2337-11e8-bb31-277e215e09e6/5aa1e025dfd39.image.jpg?crop=730%2C411%2C0%2C75&resize=200%2C113&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/content/tncms/assets/v3/editorial/4/10/410f1484-2337-11e8-bb31-277e215e09e6/5aa1e025dfd39.image.jpg?crop=730%2C411%2C0%2C75&resize=300%2C169&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/content/tncms/assets/v3/editorial/4/10/410f1484-2337-11e8-bb31-277e215e09e6/5aa1e025dfd39.image.jpg?crop=730%2C411%2C0%2C75&resize=400%2C225&order=crop%2Cresize 400w, https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/content/tncms/assets/v3/editorial/4/10/410f1484-2337-11e8-bb31-277e215e09e6/5aa1e025dfd39.image.jpg?crop=730%2C411%2C0%2C75&resize=540%2C304&order=crop%2Cresize 540w, https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/content/tncms/assets/v3/editorial/4/10/410f1484-2337-11e8-bb31-277e215e09e6/5aa1e025dfd39.image.jpg?crop=730%2C411%2C0%2C75&resize=730%2C411&order=crop%2Cresize 881w" />
                </a>
                
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body"><div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="/opinion/editorials/grenada-37-years-later/article_7e9a8a48-17e2-11eb-bb19-d3db743fecbd.html" class="tnt-asset-link">
        

        
            Grenada, 37  years later</a></h3></div>
                    
                    
                    
                    
                        
                        
                            <div class="card-lead">
                                <p class="tnt-summary">CARIBBEAN countries joined with others across the world on Sunday to mark the 37th anniversary of the collapse of a socialist experiment which had been undertaken neighbouring Grenada four and half years earlier, on March 13, 1979.</p>
                            </div>
                        
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
                </div>
                
            
            
            
                
            
            
        <div class=" col-sm-4 ">
                 
                                
                    <article id="card-summary-636623-352c7ae2-17e2-11eb-9fdb-c7c465dc5fa8" class="tnt-asset-type-article clearfix card summary has-image image-top dark letterbox-style-default  tnt-section-opinion tnt-sub-section-columnists">
            <div class="card-container"><div class="card-image card-image-top">
                        <div class="media-preview-352c7ae2-17e2-11eb-9fdb-c7c465dc5fa8 media-preview article-asset" data-aspect="16:9"><figure class="photo layout-horizontal letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/opinion/columnists/how-rowley-combats-the-plague-besetting-t-t/article_352c7ae2-17e2-11eb-9fdb-c7c465dc5fa8.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAJCAQAAACRI2S5AAAAEklEQVR42mM8U8+AFzCOKgADAHdUC60wg0dkAAAAAElFTkSuQmCC"
                            alt="How Rowley combats the plague besetting T&amp;T"
                            class="img-responsive lazyload full default"
                            width="476"
                            height="268"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/content/tncms/assets/v3/editorial/7/e7/7e726e2e-1f55-11e8-a312-4795dce77eb1/5a9b5cfe61415.image.jpg?crop=476%2C268%2C0%2C166&resize=200%2C113&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/content/tncms/assets/v3/editorial/7/e7/7e726e2e-1f55-11e8-a312-4795dce77eb1/5a9b5cfe61415.image.jpg?crop=476%2C268%2C0%2C166&resize=300%2C169&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/content/tncms/assets/v3/editorial/7/e7/7e726e2e-1f55-11e8-a312-4795dce77eb1/5a9b5cfe61415.image.jpg?crop=476%2C268%2C0%2C166&resize=400%2C225&order=crop%2Cresize 400w, https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/content/tncms/assets/v3/editorial/7/e7/7e726e2e-1f55-11e8-a312-4795dce77eb1/5a9b5cfe61415.image.jpg?crop=476%2C268%2C0%2C166&resize=476%2C268&order=crop%2Cresize 540w" />
                </a>
                
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body"><div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="/opinion/columnists/how-rowley-combats-the-plague-besetting-t-t/article_352c7ae2-17e2-11eb-9fdb-c7c465dc5fa8.html" class="tnt-asset-link">
        

        
            How Rowley combats the plague besetting T&T</a></h3></div>
                    
                    
                    
                    
                        
                        
                            <div class="card-lead">
                                <p class="tnt-summary">This too shall pass.</p>
                            </div>
                        
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
                </div>
                
            
            
            
                
            
            
        <div class=" col-sm-4 ">
                 
                                
                    <article id="card-summary-636623-cafb224a-17e1-11eb-9ab9-638900c81e92" class="tnt-asset-type-article clearfix card summary has-image image-top dark letterbox-style-default  tnt-section-opinion tnt-sub-section-columnists">
            <div class="card-container"><div class="card-image card-image-top">
                        <div class="media-preview-cafb224a-17e1-11eb-9ab9-638900c81e92 media-preview article-asset" data-aspect="16:9"><figure class="photo layout-horizontal letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/opinion/columnists/statutory-ambiguity/article_cafb224a-17e1-11eb-9ab9-638900c81e92.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAJCAQAAACRI2S5AAAAEklEQVR42mM8U8+AFzCOKgADAHdUC60wg0dkAAAAAElFTkSuQmCC"
                            alt="Statutory ambiguity"
                            class="img-responsive lazyload full default"
                            width="730"
                            height="411"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/content/tncms/assets/v3/editorial/d/f9/df990da6-9a61-5f66-8a6d-d70f14744e2b/5ab3ca95a998d.image.jpg?crop=730%2C411%2C0%2C75&resize=200%2C113&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/content/tncms/assets/v3/editorial/d/f9/df990da6-9a61-5f66-8a6d-d70f14744e2b/5ab3ca95a998d.image.jpg?crop=730%2C411%2C0%2C75&resize=300%2C169&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/content/tncms/assets/v3/editorial/d/f9/df990da6-9a61-5f66-8a6d-d70f14744e2b/5ab3ca95a998d.image.jpg?crop=730%2C411%2C0%2C75&resize=400%2C225&order=crop%2Cresize 400w, https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/content/tncms/assets/v3/editorial/d/f9/df990da6-9a61-5f66-8a6d-d70f14744e2b/5ab3ca95a998d.image.jpg?crop=730%2C411%2C0%2C75&resize=540%2C304&order=crop%2Cresize 540w, https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/content/tncms/assets/v3/editorial/d/f9/df990da6-9a61-5f66-8a6d-d70f14744e2b/5ab3ca95a998d.image.jpg?crop=730%2C411%2C0%2C75&resize=730%2C411&order=crop%2Cresize 881w" />
                </a>
                
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body"><div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="/opinion/columnists/statutory-ambiguity/article_cafb224a-17e1-11eb-9ab9-638900c81e92.html" class="tnt-asset-link">
        

        
            Statutory ambiguity</a></h3></div>
                    
                    
                    
                    
                        
                        
                            <div class="card-lead">
                                <p class="tnt-summary">THE decision of the Court of Appeal has drawn a line under the litigation between the Trinidad and Tobago Football Association (TTFA) and FIFA, a conflict which recalls the Creole aphorism: “Tief from tief does make God laugh!” Justice Gobin took the parties and the country on an excursion which brought to mind former Chief Justice Michael de la Bastide’s query, posed in the context of another matter adjudicated by Gobin J, as to whether judicial review legislation had opened the door to “judicial adventurism’’.</p>
                            </div>
                        
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
                </div>
                
            
            
            
                
                    <div class="clearfix hidden-xs"></div>
                
            
            
        <div class=" col-sm-4 ">
                 
                                
                    <article id="card-summary-636623-fbbff744-17e0-11eb-9e11-ff64a04fcfac" class="tnt-asset-type-article clearfix card summary has-image image-top dark letterbox-style-default  tnt-section-opinion tnt-sub-section-letters">
            <div class="card-container"><div class="card-image card-image-top">
                        <div class="media-preview-fbbff744-17e0-11eb-9e11-ff64a04fcfac media-preview article-asset" data-aspect="16:9"><figure class="photo layout-horizontal letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/opinion/letters/blame-mps-not-police-for-crime/article_fbbff744-17e0-11eb-9e11-ff64a04fcfac.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAJCAQAAACRI2S5AAAAEklEQVR42mM8U8+AFzCOKgADAHdUC60wg0dkAAAAAElFTkSuQmCC"
                            alt="Blame MPs, not police for crime"
                            class="img-responsive lazyload full default"
                            width="1083"
                            height="609"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/content/tncms/assets/v3/editorial/9/ff/9ff6cfec-e1bb-11ea-9382-c3367581f440/5f3c80ddf36bd.image.jpg?crop=1083%2C609%2C58%2C0&resize=200%2C113&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/content/tncms/assets/v3/editorial/9/ff/9ff6cfec-e1bb-11ea-9382-c3367581f440/5f3c80ddf36bd.image.jpg?crop=1083%2C609%2C58%2C0&resize=300%2C169&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/content/tncms/assets/v3/editorial/9/ff/9ff6cfec-e1bb-11ea-9382-c3367581f440/5f3c80ddf36bd.image.jpg?crop=1083%2C609%2C58%2C0&resize=400%2C225&order=crop%2Cresize 400w, https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/content/tncms/assets/v3/editorial/9/ff/9ff6cfec-e1bb-11ea-9382-c3367581f440/5f3c80ddf36bd.image.jpg?crop=1083%2C609%2C58%2C0&resize=540%2C304&order=crop%2Cresize 540w, https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/content/tncms/assets/v3/editorial/9/ff/9ff6cfec-e1bb-11ea-9382-c3367581f440/5f3c80ddf36bd.image.jpg?crop=1083%2C609%2C58%2C0&resize=881%2C496&order=crop%2Cresize 881w, https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/content/tncms/assets/v3/editorial/9/ff/9ff6cfec-e1bb-11ea-9382-c3367581f440/5f3c80ddf36bd.image.jpg?crop=1083%2C609%2C58%2C0&resize=1083%2C609&order=crop%2Cresize 1396w" />
                </a>
                
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body"><div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="/opinion/letters/blame-mps-not-police-for-crime/article_fbbff744-17e0-11eb-9e11-ff64a04fcfac.html" class="tnt-asset-link">
        

        
            Blame MPs, not police for crime</a></h3></div>
                    
                    
                    
                    
                        
                        
                            <div class="card-lead">
                                <p class="tnt-summary">When will we stop casting blame single-handedly on the police for our horrendous crime situation?</p>
                            </div>
                        
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
                </div>
                
            
            
            
                
            
            
        <div class=" col-sm-4 ">
                 
                                
                    <article id="card-summary-636623-dee879ac-17e0-11eb-a68f-27c2cb9d648f" class="tnt-asset-type-article clearfix card summary dark letterbox-style-default  tnt-section-opinion tnt-sub-section-letters">
            <div class="card-container">
                
                <div class="card-body"><div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="/opinion/letters/glitches-making-peter-pay-for-paul/article_dee879ac-17e0-11eb-a68f-27c2cb9d648f.html" class="tnt-asset-link">
        

        
            glitches making  Peter pay for Paul?</a></h3></div>
                    
                    
                    
                    
                        
                        
                            <div class="card-lead">
                                <p class="tnt-summary">IT is passing strange that the judiciary is facing computer system issues which affect its duty and responsibility to the people it serves.</p>
                            </div>
                        
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
                </div>
                
            
            
            
                
            
            
        <div class=" col-sm-4 last-grid-item">
                 
                                
                    <article id="card-summary-636623-2e788bce-17e1-11eb-8e3a-dffaf1bafc2f" class="tnt-asset-type-article clearfix card summary has-image image-top dark letterbox-style-default  tnt-section-opinion tnt-sub-section-columnists">
            <div class="card-container"><div class="card-image card-image-top">
                        <div class="media-preview-2e788bce-17e1-11eb-8e3a-dffaf1bafc2f media-preview article-asset" data-aspect="16:9"><figure class="photo layout-horizontal letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/opinion/columnists/calypso-lyrics-more-than-simple-poetry/article_2e788bce-17e1-11eb-8e3a-dffaf1bafc2f.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAJCAQAAACRI2S5AAAAEklEQVR42mM8U8+AFzCOKgADAHdUC60wg0dkAAAAAElFTkSuQmCC"
                            alt="Calypso lyrics: more than simple poetry"
                            class="img-responsive lazyload full default"
                            width="400"
                            height="225"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/content/tncms/assets/v3/editorial/1/82/1823cb98-1b0b-11e8-b16e-838e121abd18/5a942a1a14185.image.jpg?crop=400%2C225%2C0%2C72&resize=200%2C113&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/content/tncms/assets/v3/editorial/1/82/1823cb98-1b0b-11e8-b16e-838e121abd18/5a942a1a14185.image.jpg?crop=400%2C225%2C0%2C72&resize=300%2C169&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/content/tncms/assets/v3/editorial/1/82/1823cb98-1b0b-11e8-b16e-838e121abd18/5a942a1a14185.image.jpg?crop=400%2C225%2C0%2C72&resize=400%2C225&order=crop%2Cresize 400w" />
                </a>
                
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body"><div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="/opinion/columnists/calypso-lyrics-more-than-simple-poetry/article_2e788bce-17e1-11eb-8e3a-dffaf1bafc2f.html" class="tnt-asset-link">
        

        
            Calypso lyrics: more than simple poetry</a></h3></div>
                    
                    
                    
                    
                        
                        
                            <div class="card-lead">
                                <p class="tnt-summary">Journalist Tony Fraser invited me on Power 102 Radio this week to discuss ‘’Language in Calypso,” in conjunction with Calypso History Month. I happily accepted his invitation, since one of the objectives of this special month for this special art form is to bring to the attention of the public some of the beautiful excerpts written by calypsonians over the years.</p>
                            </div>
                        
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
                </div>
                
            
            
            
                
                    <div class="clearfix hidden-xs"></div>
                
            
            
        
        <div class="clearfix hidden-xs"></div>
        
        
        </div>
        </div></section></div></div>

                    <div class="asset-comments hidden-print"></div>
                    
                    <div id="tncms-region-article_container_bottom" class="tncms-region hidden-print"></div></div>
            </div>

            
            </div>
        </div><div class="main-sidebar col-lg-4 col-md-5 hidden-print">
                <div class="main-sidebar-wrap">
                    <div id="tncms-region-article_side_top" class="tncms-region hidden-print"></div><div id="tncms-region-asset_side_top" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-primary" class="tncms-region "><div id="tncms-block-631850" class="tncms-block grey-ad hidden-xs hidden-sm"><div class="tnt-ads-container text-center  " >
        <div id="ad-631850" class="tnt-ads dfp-ad" data-always-load="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-631850');
                        
                });
            </script>
        </div>
    </div>
</div><div id="tncms-block-634987" class="tncms-block"><div class="small-title">TRENDING</div></div><div id="tncms-block-643313" class="tncms-block trending-stories"><section id="block-643313" class="block emphasis-h3 dark  " >
    <div class="card">
        <ul class="list-unstyled list-popular"><li>
                    
                        <h4 class="tnt-headline ">
        
             <a href="/opinion/columnists/of-conformity-and-stupidity/article_19f630f8-1650-11eb-8404-331f6bc84b0a.html" class="tnt-asset-link">
        

        
            Of conformity and stupidity</a></h4>
                    
                </li><li>
                    
                        <h4 class="tnt-headline ">
        
             <a href="/opinion/columnists/the-power-of-pride/article_999bf00c-158a-11eb-a5a0-ef45a3bae690.html" class="tnt-asset-link">
        

        
            The power of pride</a></h4>
                    
                </li><li>
                    
                        <h4 class="tnt-headline ">
        
             <a href="/opinion/columnists/dr-rowley-s-dangerous-diatribe/article_1d34e058-10d2-11eb-8f08-2f34512b7c14.html" class="tnt-asset-link">
        

        
            Dr Rowley’s dangerous diatribe</a></h4>
                    
                </li><li>
                    
                        <h4 class="tnt-headline ">
        
             <a href="/opinion/columnists/danger-between-headline-and-bottom-line/article_0e21a498-164f-11eb-8e49-27c2ff57f142.html" class="tnt-asset-link">
        

        
            Danger Between Headline and Bottom line</a></h4>
                    
                </li><li>
                    
                        <h4 class="tnt-headline ">
        
             <a href="/opinion/columnists/help-workers-who-are-victims-of-violence/article_972ee61e-d10a-11e9-bd75-5ff663ae7d17.html" class="tnt-asset-link">
        

        
            Help workers who are  victims of violence</a></h4>
                    
                </li></ul>
    </div>
    
</section></div><div id="tncms-block-632079" class="tncms-block grey-ad hidden-xs hidden-sm"><div class="tnt-ads-container text-center  " >
        <div id="ad-632079" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-632079');
                        
                });
            </script>
        </div>
    </div>
</div><div id="tncms-block-631846" class="tncms-block news-tip first-story-border"><section id="block-631846" class="block emphasis-h3   " ><article class="card promo media card-img-sm"><figure class="pull-left"><a href="/submit_news">
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/content/tncms/custom/image/c487cc0a-fa3e-11e8-b837-8f6db91a652d.png" 
                data-sizes="auto" 
                class="img-default img-responsive lazyload tnt-prop-img"
                alt=""></a></figure><div class="media-body"><h3 class="media-heading">Do you have a news tip?</h3><p>Want to share good news story, or do you have information that should see the light of day? Then we want to hear from you.</p><a href="/submit_news">
                <button type="button" class="btn btn-default btn-sm">More here</button>
            </a></div>
</article></section></div><div id="tncms-block-632080" class="tncms-block grey-ad hidden-xs hidden-sm"><div class="tnt-ads-container text-center  " >
        <div id="ad-632080" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-632080');
                        
                });
            </script>
        </div>
    </div>
</div><div id="tncms-block-632082" class="tncms-block"><div class="">
			<div class="tabbable" id="tabs-558249">
				<ul class="nav nav-tabs">
<li class="active" id="fbtab">
						<a href="#panel-497561" data-toggle="tab">Facebook</a>
					</li>
					<li id="twtab">
						<a href="#panel-967378" data-toggle="tab">Twitter</a>
					</li>
					<li id="igtab">
						<a href="#panel-967379" data-toggle="tab">Instagram</a>
					</li>
				</ul>
<div class="tab-content">
					<div class="tab-pane active" id="panel-497561">
						<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.5&appId=1550124928647000";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script><div class="fb-page" data-href="https://www.facebook.com/ExpressNewspapers" data-small-header="true" data-adapt-container-width="true" data-hide-cover="false" data-show-facepile="true" data-show-posts="true" style="margin-left:10px" data-height="650"><div class="fb-xfbml-parse-ignore"><blockquote cite="https://www.facebook.com/ExpressNewspapers"><a href="https://www.facebook.com/ExpressNewspapers"></a></blockquote></div></div>
<div class="padding-top padding-bottom"></div>
					</div>
					<div class="tab-pane" id="panel-967378">
						<a class="twitter-timeline" href="https://twitter.com/expressupdates" data-height="650">Tweets by expressupdates</a> <script async src="//platform.twitter.com/widgets.js" charset="utf-8"></script><div class="padding-top padding-bottom"></div>
					</div>
					<div class="tab-pane" id="panel-967379">
						<p>
							Instagram
						</p>
					</div>
				</div>
			</div>
		</div></div></div><div id="tncms-region-asset_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-article_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-secondary" class="tncms-region hidden-print"></div><div id="tncms-region-asset_side_bottom" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-tertiary" class="tncms-region "></div><div id="tncms-region-article_side_bottom" class="tncms-region hidden-print"></div>
                <div id="sticky-right-rail-spacer">
                    <div id="sticky-right-rail"><div id="tncms-region-global-side-sticky" class="tncms-region hidden-print"></div><div id="tncms-region-asset_side_sticky" class="tncms-region hidden-print"></div></div>
                </div>
                </div>
            </div></div>
</article>
<div class="row">
            <div class="col-md-12"><div id="tncms-region-global-container-bottom" class="tncms-region "></div></div>
        </div></section>
    <section id="main-bottom-container" class="container-fullscreen-region container-fluid">
        <div class="fullscreen-region"><div id="tncms-region-global-container-bottom-fullscreen" class="tncms-region "></div></div>
    </section><!-- / main-body-container -->
    </div>
    <div id="site-footer-container" class="hidden-print">
         
            <div class="container">
                <div id="asset-container-bottom" class="col-md-12">
                    <div id="tncms-region-asset_container_bottom" class="tncms-region hidden-print"></div> 
                </div>
            </div>
        

        
            <footer id="site-footer" class="container_fluid well-main">
                
                <div id="tncms-region-footer-top-col-full" class="tncms-region "><div id="tncms-block-615295" class="tncms-block padding-bottom padding-left padding-top"><div id="site-logo-615295" class="site-logo-container text-left" >
        <div class="logo-top"></div>
        <div class="logo-middle">
            <a  href="/"><img 
            
            src="https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/content/tncms/custom/image/94babfee-1049-11e8-bdb4-43f4dabff0f2.png?resize=200%2C22" 
            srcset="https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/content/tncms/custom/image/94babfee-1049-11e8-bdb4-43f4dabff0f2.png?resize=200%2C22 200w, https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/content/tncms/custom/image/94babfee-1049-11e8-bdb4-43f4dabff0f2.png?resize=300%2C34 300w, https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/content/tncms/custom/image/94babfee-1049-11e8-bdb4-43f4dabff0f2.png?resize=400%2C45 400w, https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/content/tncms/custom/image/94babfee-1049-11e8-bdb4-43f4dabff0f2.png 540w"
            sizes="(min-width: 1396px) calc(100.00vw - 30px), 100vw"
            class=" img-responsive lazyload tnt-prop-img"
            alt="site-logo"></a>
        </div>
        <div class="logo-bottom"></div>
    </div></div><div id="tncms-block-726251" class="tncms-block"><meta name="viewport" content="width=device-width, initial-scale=1">
<style>
html {
  scroll-behavior: smooth;
}
body {

}

#myBtn {
  display: none;
  position: fixed;
  bottom: 20px;
  right: 30px;
  z-index: 99;
  font-size: 18px;
  border: none;
  outline: none;
  background-color: red;
  color: white;
  cursor: pointer;
  padding: 15px;
  border-radius: 4px;
}

#myBtn:hover {
  background-color: #555;
}
</style>
<button onclick="topFunction()" id="myBtn" title="Go to top">Top</button><script>
// When the user scrolls down 20px from the top of the document, show the button
window.onscroll = function() {scrollFunction()};

function scrollFunction() {
  if (document.body.scrollTop > 20 || document.documentElement.scrollTop > 20) {
    document.getElementById("myBtn").style.display = "block";
  } else {
    document.getElementById("myBtn").style.display = "none";
  }
}

// When the user clicks on the button, scroll to the top of the document
function topFunction() {
  document.body.scrollTop = 0;
  document.documentElement.scrollTop = 0;
}
</script></div><div id="tncms-block-631922" class="tncms-block"><div class="col-md-12 footer-nav">
			<div class="row">
				<div class="col-md-3 col-sm-6">
					<h4>
						<a href="/news/">News</a>
					</h4>
					<ul class="list-unstyled"><li>
							<a href="/news/local/">Local</a>
						</li>
						<li>
							<a href="/news/regional/">Regional</a>
						</li>
						<li>
							<a href="/news/world/">World</a>
						</li>
						
					</ul></div>
				<div class="col-md-3 col-sm-6">
				<h4>
						<a href="/sports/">Sports</a>
					</h4>
					<ul class="list-unstyled"><li>
							<a href="/sports/local/">Local</a>
						</li>
						<li>
							<a href="/sports/regional/">Regional</a>
						</li>
						<li>
							<a href="/sports/world/">World</a>
						</li>
						<li>
							<a href="/sports/world/football/">Football</a>
						</li>
						<li>
							<a href="/sports/world/basketball/">Basketball</a>
						</li>
						<li>
							<a href="/sports/world/cricket/">Cricket</a>
						</li>
						<li>
							<a href="/sports/">More</a>
						</li>						
						
						
						
						
					</ul></div>
<div class="clearfix visible-sm"></div>
				<div class="col-md-3 col-sm-6">
				<h4>
						<a href="/business/">Business</a>
					</h4>
					<ul class="list-unstyled"><li>
							<a href="/business/local/">Local</a>
						</li>
						<li>
							<a href="/business/regional/">Regional</a>
						</li>
						<li>
							<a href="/business/world/">World</a>
						</li>
						
					</ul></div>
				<div class="col-md-3 col-sm-6">
				<h4>
						<a href="/features/">Features</a>
					</h4>
					<ul class="list-unstyled"><li>
							<a href="/features/local/">Local</a>
						</li>
						<li>
							<a href="/features/editorial/">Editorial</a>
						</li>
						<li>
							<a href="/features/woman/">Woman</a>
						</li>
						
					</ul></div>
			</div>
			<div class="row">
				<div class="col-md-3 col-sm-6">
				<h4>
						<a href="/opinion/editorials/">Editorial</a>
					</h4>
					<ul class="list-unstyled"><li>
							<a href="/opinion/editorials/">Express Editorial</a>
						</li>
						<li>
							<a href="/opinion/contributors/">Contributors</a>
						</li>
						
						
					</ul></div>
				<div class="col-md-3 col-sm-6">
				<h4>
						<a href="/opinion/letters/">Letters</a>
					</h4>
					<ul class="list-unstyled"><li>
							<a href="/opinion/letters/">Local</a>
						</li>
					
						
						
					</ul></div>
<div class="clearfix visible-sm"></div>
				<div class="col-md-3 col-sm-6">
				<h4>
						<a href="/news/world/">World</a>
					</h4>
					<ul class="list-unstyled"><li>
							<a href="/news/us/">U.S.</a>
						</li>
						<li>
							<a href="/news/world/">Rest of the World</a>
						</li>
						
						
					</ul></div>
				<div class="col-md-3 col-sm-6">
				<h4>
						<a href="http://digital.trinidadexpress.com/">Subscription</a>
					</h4>
					<ul class="list-unstyled"><li>
							<a href="http://digital.trinidadexpress.com/">Local</a>
						</li>
						<li>
							<a href="http://digital.trinidadexpress.com/">Regional</a>
						</li>
						<li>
							<a href="http://digital.trinidadexpress.com/">World</a>
						</li>
						
					</ul></div>
			</div>
			<div class="row">
				<div class="col-md-3 col-sm-6">
				<h4>
						<a href="/site/contact.html">Contact Us</a>
					</h4>
					<ul class="list-unstyled"><li>
							<a href="/site/contact.html">Make Contact</a>
						</li>
					
						
						
					</ul></div>
				<div class="col-md-3 col-sm-6">
				<h4>
						<a href="/site/advertise.html">Advertising</a>
					</h4>
					<ul class="list-unstyled"><li>
							<a href="/site/advertise.html">Trinidad Express</a>
						</li>
						<li>
							<a href="/site/advertise.html">Express Classifieds</a>
						</li>
						<li>
							<a href="/site/advertise.html">Agency</a>
						</li>
						<li>
							<a href="/site/advertise.html">Direct</a>
						</li>
					</ul></div>
<div class="clearfix visible-sm"></div>
				<div class="col-md-3 col-sm-6">
				<h4>
						<a href="/site/contact.html">Feedback</a>
					</h4>
					<ul class="list-unstyled"><li>
							<a href="/site/contact.html">Let us know</a>
						</li>
					
						
						
					</ul></div>
				<div class="col-md-3 col-sm-6">
<h4>
						<a href="/site/advertise.html">Social Channels</a>
					</h4>
					<ul class="list-unstyled"><li>
							<a href="https://www.facebook.com/ExpressNewspapers"><i class="fab tnt-facebook-square" aria-hidden="true"></i>
 Facebook</a>
						</li>
						<li>
							<a href="http://twitter.com/expressupdates/"><i class="fab tnt-twitter" aria-hidden="true"></i>
 Twitter</a>
						</li>
						<li>
							<a href="https://www.instagram.com/trinidadexpress/"><i class="fab tnt-instagram" aria-hidden="true"></i>
 Instagram</a>
						</li>
				
					</ul></div>
			</div>
			
			
			<div class="row">
				<div class="col-md-12 text-right copyright-text">© 2020 Caribbean Communication Network.  One Caribbean Media.  All Rights Reserved.<br><a href="/site/about.html">About Us</a> | <a href="/site/terms.html">Terms of Use</a> | <a href="/site/privacy.html">Privacy Policy</a> | <a href="/site/refund.html">Refund Policy</a>
				
				</div>
			</div>
			
		</div></div></div>
                <div class="row">
                    <div id="footer-col-one" class="col-md-6 col-sm-6"><div id="tncms-region-footer-col-one" class="tncms-region "></div></div>
    <div id="footer-col-two" class="col-md-6 col-sm-6"><div id="tncms-region-footer-col-two" class="tncms-region "></div></div>
                </div>
                <div id="tncms-region-footer-bottom-col-full" class="tncms-region "></div>
                
 



<script type='text/javascript'>
    var _sf_async_config={};
    /** CONFIGURATION START **/
    _sf_async_config.uid = 61692;
    _sf_async_config.domain = 'trinidadexpress.com';
    _sf_async_config.useCanonical = true;
    _sf_async_config.sections = 'Opinion';  
    _sf_async_config.authors = 'TrinidadExpress.com';  
    /** CONFIGURATION END **/
    (function(){
      function loadChartbeat() {
        window._sf_endpt=(new Date()).getTime();
        var e = document.createElement('script');
        e.setAttribute('language', 'javascript');
        e.setAttribute('type', 'text/javascript');
        e.setAttribute('src', '//static.chartbeat.com/js/chartbeat.js');
        document.body.appendChild(e);
      }
      var oldonload = window.onload;
      window.onload = (typeof window.onload != 'function') ?
         loadChartbeat : function() { oldonload(); loadChartbeat(); };
    })();
</script><script type="text/javascript" async="async" src="//trinidadexpress-tto-pw.newsmemory.com/?meter&amp;v=0"></script><script type="text/javascript">
window._taboola = window._taboola || [];
_taboola.push({flush: true});
</script>
            </footer>
        

        <div id="site-copyright-container" class="container_fluid">
            <div id="tncms-region-footer-copyright" class="tncms-region "></div>
        </div>
    </div>
    
    
        </div><!-- / offcanvas close  -->
    

    <div id="notification-panel" class="notify-panel notify-panel-from-right">
            <template>
                <div class="notification-item">
                    <a href="{{url}}" target="_blank"></a>
                    <div class="notification-item-card">
                        <div class="notification-item-image"><img src="{{image}}"></div>
                        <div class="notification-item-content">
                            <div class="notification-item-header">{{title}}</div>
                            <div class="notification-item-summary">{{summary}}</div>
                        </div>
                    </div>
                    <div class="notification-item-dismiss">
                        <i class="fas tnt-times tnt-fw"></i>
                    </div>
                </div>
            </template>
            <div class="notify-panel-container">
                <div class="notify-panel-header">
                    <div class="notify-panel-close"><i class="fas tnt-times tnt-fw"></i></div>
                    <div class="notify-panel-nav" role="tablist">
                        <ul>
                            <li class="active" role="presentation"><a href="#notify-panel-content" role="tab" data-toggle="tab">Notifications</a></li>
                            <li role="presentation"><a href="#notify-panel-settings" role="tab" data-toggle="tab">Settings</a></li>
                        </ul>
                    </div>
                </div>
                <div class="tab-content">
                    <div id="notify-panel-content" class="tab-pane active" role="tabpanel">
                        <div class="notify-panel-content-items"></div>
                        <div class="notify-panel-content-no-items" style="display:none;">You don't have any notifications.</div>
                    </div>
                    <div id="notify-panel-settings" class="tab-pane" role="tabpanel">
                        <div class="notify-panel-settings-promo">
                            <p>Get up-to-the-minute news sent straight to your device.</p>
                        </div>
                        
                        <h5>Topics</h5>
                        
                            <div class="topic-container" data-name="Express">
                                <h4>Push notification</h4>
                                <label class="switch-label">
                                    <span class="sr-only">Subscribe</span>
                                    <input id="topic-Express" class="switch-input" title="topic-Express" name="topic-Express" data-topic="Express" type="checkbox">
                                    <div class="switch-track"></div>
                                    <div class="switch-thumb"></div>
                                </label>
                            </div>
                        
                        
                        <div class="notify-panel-settings-error alert alert-danger" style="display:none; opacity:0;"></div>
                        <div class="notify-panel-settings-success alert alert-success" style="display:none; opacity:0;"></div>
                    </div>
                </div>
            </div>
        </div>
    <div id="sticky-anchor"><div id="tncms-region-page_sticky_anchor" class="tncms-region hidden-print collapse in"><div id="tncms-block-637662" class="tncms-block grey-ad hidden-md hidden-lg"><div class="tnt-ads-container text-center  " >
        <div id="ad-637662" class="tnt-ads dfp-ad" data-always-load="true" data-refresh="true" data-mobile-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-637662');
                        
                });
            </script>
        </div>
    </div>
</div></div></div>
    <!-- / site-container close -->
    </div>
    
    
    <script>
        window.__tnt = window.__tnt || {};
        __tnt.compatibility = __tnt.compatibility || {};

        __tnt.compatibility.status = '';
        __tnt.compatibility.check = function() {
            if (typeof __tnt.advertisements == 'undefined') {
                __tnt.compatibility.status = 'FAIL: object 0 undefined';
                return false;
            }
            return true;
        };
        __tnt.compatibility.notification = function() {
            if (!document.getElementById('notification-area')) {
                    var el = document.createElement('div');
                    el.id = 'notification-area';
                    document.querySelector('#asset-content .asset-body').appendChild(el);
                }
                __tnt.template(
                    document.getElementById('template-blox-message-incompatible'),
                    document.getElementById('notification-area'),
                    true,
                    [],
                    function(el) {
                        setTimeout(function() {
                            var message = document.getElementById('blox-message-incompatible');
                            var authStatusCls = (__tnt.user.authToken) ? 'logged-in' : 'not-logged-in';
                                Array.from(message.getElementsByClassName(authStatusCls)).forEach(function(el) {
                                    el.style.display = 'block';
                                });
                            
                            if (__tnt.user.services) {
                                message.parentNode.removeChild(message);
                            } else {
                                message.style.display = 'block';
                                }
                        }, 100);
                    }
                );
            };
        (function() {
            function compatibilityCheck() {
                if (!__tnt.compatibility.check()) {
                    __tnt.trackEvent({
                        'category':'subscription',
                        'action':'adblock',
                        'label':'adblock detected',
                        'value':'1'
                    });
                    }
            }

            if (document.readyState != 'loading') {
                compatibilityCheck();
            } else {
                document.addEventListener('DOMContentLoaded', compatibilityCheck);
            }
        })();
    </script>
    <template id="template-blox-message-incompatible">
            </template>
    
    
    <script>
        jQuery(function() {
            if(typeof TNCMS.Tracking != 'undefined'){
                jQuery(TNCMS.Tracking.trackDeclarativeEvents);
            }dataLayer.push({'tncms.client.recent_five':__tnt.recentFive.add("7e9a8a48-17e2-11eb-bb19-d3db743fecbd")});});
    </script>

    <script>
        __tnt.trackEvent = function(obj) {
            if (typeof obj === 'object') {
                    if (obj.category && obj.action) {
                        __tnt.googleEvent(obj);
                    } else if (obj.network && obj.socialAction) {
                        __tnt.googleSocial(obj);
                    } else if (obj.url) {
                        __tnt.googlePageView(obj);
                    }
                    if (typeof TNCMS.Tracking != 'undefined' && obj.metric) {
                        TNCMS.Tracking.addEvent({
                            app: obj.app,
                            metric: obj.metric,
                            id: obj.uuid
                        });
                    }
            }
        };

        if (__tnt.trackEventLater.length > 0) {
            __tnt.trackEventLater.forEach(function(obj) {
                __tnt.trackEvent(obj);
            });
        }

        Array.from(document.querySelectorAll('body [data-track]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.track));
            });
        });
        Array.from(document.querySelectorAll('body [data-tncms-track-event]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.tncmsTrackEvent));
            });
        });
        
        Array.from(document.querySelectorAll('body [data-tncms-track-dmp]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                var dmpData = el.dataset.tncmsTrackDmp;
                
            });
        });
    
    </script>
    
    <script type="text/javascript"> var infolinks_pid = 3184707; var infolinks_wsid = 0; </script> <script type="text/javascript" src="//resources.infolinks.com/js/infolinks_main.js"></script>
<script>/*<![CDATA[*/ 
                __tnt.googleEvent = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.trigger',
                             'tncms.event.trigger.category': obj.category,
                             'tncms.event.trigger.action': obj.action,
                             'tncms.event.trigger.label': obj.label, 
                             'tncms.event.trigger.value': obj.value
                    });
                }
                /* Virtual page view */
                __tnt.googlePageView = function(obj) {
                    var sURL = obj.url.replace(/^.*\/\/[^\/]+/, '');
                    dataLayer.push({
                        'event': 'tncms.event.virtual_pageview',
                            'tncms.event.virtual_pageview.url': sURL,
                            'tncms.event.virtual_pageview.title': obj.title
                    });
                }
                /* Social event */
                __tnt.googleSocial = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.social',
                            'tncms.event.social.network': obj.network,
                            'tncms.event.social.action': obj.socialAction,
                            'tncms.event.social.target': obj.url
                    });
                } /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/asset-edit.60e8e67e04be1194326dcfbe7f00b8c3.js"></script>
<script>/*<![CDATA[*/ $(function() {
        var avatar_615302 = $('#user-controls-615302 .tn-user-avatar');
        if(__tnt.user.loggedIn && __tnt.user.avatar){
            avatar_615302.append('<img src="' + __tnt.user.avatar + '" class="user-icon">');
        } else{
            avatar_615302.append('<i class="fas tnt-user tnt-fw user-icon"></i>');
        }
    }); /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/tnt.ads.core.dff62462821a09a08cb5a44c8d59b2ea.js"></script>
<script>/*<![CDATA[*/ function articleShareSticky(){
                setTimeout(function(){
                    var sMainTop = document.querySelector('#main-body-container').offsetTop,
                        oNavBar = document.querySelector('#site-navbar-container');
                    if (sMainTop < window.scrollY){
                        oNavBar.classList.add('article-share')
                    } else {
                        oNavBar.classList.remove('article-share')
                    }
                }, 150)
            }
            document.addEventListener('scroll', articleShareSticky); /*]]>*/</script>
<script>/*<![CDATA[*/ !function(t,i,n){var e,a,s,o,c,d={init:function(){a=i.getElementById("site-navbar-container"),n.client.platform.ios?a.classList.add("affix-sticky"):(e=i.getElementById("main-body-container"),s=a.offsetHeight||a.clientHeight,o=!1,c=0,t.addEventListener("scroll",d.navPosition,!1),t.addEventListener("mousewheel",d.navPosition,!1))},navPosition:function(){o||(o=!0,setTimeout(function(){var n=a.getBoundingClientRect(),d=t.pageYOffset||i.documentElement.scrollTop,f=n.top+d;d>=f&&d>c?a.classList.contains("affix")||(c=f,a.classList.add("affix"),a.classList.remove("affix-top"),e.style.marginTop=s+"px"):a.classList.contains("affix-top")||(a.classList.remove("affix"),a.classList.add("affix-top"),e.style.marginTop="0px"),o=!1},25))}};"loading"==i.readyState?i.addEventListener("DOMContentLoaded",d.init,!1):d.init()}(window,document,__tnt); /*]]>*/</script>
<script>/*<![CDATA[*/ 
            // Observer callback
            var callback = function(entries, io) {
                entries.forEach(function(e) {
                    if (e.isIntersecting === true) {
                        __tnt.template(
                            document.querySelector('#' + e.target.id + ' template'),
                            document.getElementById(e.target.id),
                            false,
                            objectFitImages('#' + e.target.id + ' img') // IE11 objectfit polyfill
                        );
                        // Kill observer
                        io.unobserve(e.target);
                    }
                });
            };
            // Initialize observer
            window.addEventListener('load', function() {
                var io = new IntersectionObserver(callback),
                    targets = Array.from(document.querySelectorAll('[data-lazy-content]')); // IE11 forEach support
                targets.forEach(function(e){
                    io.observe(e);
                });
            }, false) /*]]>*/</script>
<script>/*<![CDATA[*/ function messagingCallback(oPayload) {
                __tnt.notify({
                    title: oPayload.title,
                    message: oPayload.body,
                    url: oPayload.url,
                    image: oPayload.icon,
                    duration: 6000,
                    utm: {
                        'utm_source':'BLOX Broadcast',
                        'utm_campaign':'Push Notification',
                        'utm_medium':'referral',
                        'utm_content':'in-page notification'
                    }
                }).showNotification();
            } /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/trinidadexpress.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.regions.54d9f15b0d238de6bb20ec82ed8307ac.js"></script>
<script>/*<![CDATA[*/ __tnt.regions.stickyAnchor.init(); /*]]>*/</script></body>
</html>